Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am using a Dell Vostro 1015, and when I play games in full-screen mode, the display runs an 800x600 resolution. The rest of the screen is blacked-out.

My laptop is a wide screen, but games display only in the center of the screen at 800x600 resolution.

How can I get the games to scale up to fill the screen?

share|improve this question

3 Answers 3

Your games are probably running at 800x600, but rather than scaling the image to take up the full screen, your display is showing it at its native resolution (1 game pixel == 1 LCD pixel).

The first thing you'll want to try is increasing the video resolution in the game's options. According to Dell, the native resolution of your display is 1366 X 768.

Two problems you might run into:

  1. The game doesn't provide any options to change the resolution.
  2. Your laptop isn't powerful enough to run the game at a higher resolution, and performance suffers.

Most video drivers have a setting somewhere that controls whether to scale full-screen apps to the maximum size of the screen or to show them at the native resolution. If you can't change the actual resolution that the game runs at, you'll want to look for this setting somewhere in your display/video options and change it so apps will be stretched to full screen. (Note: This will probably look pretty ugly. LCDs aren't very good at this, which is why the option exists in the first place.)

share|improve this answer
5  
Also do some searching around if a (usually older) game does not support your native resolution. You can sometimes find a config tweak to enable it. Though not entirely related, Widescreen Gaming Forum's Wiki can be a good resource for these tweaks. –  Jamie Schembri Nov 1 '10 at 16:38
2  
Saying LCDs are bad at this is a misnomer. The stretching is done by the GPU, not the monitor. What LCDs are bad at is showing an image if it is fed at the wrong resolution, which CRTs are better at. –  user56 Aug 14 '11 at 20:41

First check your drivers are up to date; if they are then:

  • Go to graphics in control panel, open it, and click on general settings in basic mode.
  • Change screen resolution from maximum (e.g. 1366x768) something less (e.g. 1360*768)
  • At the bottom, an option for scaling will display. Click it and set the scale to Full Screen
  • Click on Apply
share|improve this answer

Just go to graphic properties, then select general settings. After selecting it, find scaling and select full screen.

Click OK, then play the game to see difference.

share|improve this answer
1  
I don't think this answers the question. The OP's already running in full-screen mode. –  Anna Lear Nov 12 '11 at 16:32

protected by Community Jul 31 '12 at 5:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?