Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm trying to bind keys for making a huge jump and walking faster.

I added the following code in "autoexec.cfg" file:

alias "+fasterwalk"     "cl_forwardspeed 640;   +forward"
alias "+fastforward"    "cl_forwardspeed 4000;  +forward"
alias "+fastback"       "cl_backspeed    4000;  +back"
alias "-fasterwalk"     "-forward;  cl_forwardspeed 320"
alias "-fastforward"    "-forward;  cl_forwardspeed 320"
alias "-fastback"       "-back;     cl_backspeed    320"
alias "+longjump"       "+fastforward; wait; cl_upspeed 2000; +moveup; wait; -moveup; cl_upspeed 200; wait; -fastforward"
alias "-longjump"       "wait"

bind ALT "+longjump"
bind MOUSE2 "+fasterwalk"
bind UPARROW "+fastforward"
bind DOWNARROW "+fastback"

It doesn't work. When I press the ALT key, the player only jumps and lands to the exact same point. And when I press the second mouse button, the player moves forward with the default speed. Up and down arrow keys also make the player move at default speed.

It is like the cl_forwardspeed # and cl_backspeed # commands have no effect.

What am I doing wrong? How do I fix this configuration?

share|improve this question
    
You might be going over the max speed limit. According to gamewinners.com/Cheats/index.php/Quake_2_(PC) its 500. Or if its on a server you need to enable cheating. Also with sv_maxspeed you see and can set the maxspeed. And just to be safe that your script is working at all: try your longjump script with +forward +moveup commands only and not any aliases. –  Philipp Jan 14 '13 at 15:25
    
Indeed the max movement speed is 500 with a default of 200 (walk) and 300 (run). Try setting cl_forwardspeed to a very low number like 100 and see if this gives you any noticeable effect - set it in console so you get any feedback and errors and then work onwards from there. As mentioned by @Philipp the various jumps will need to be combined with moving foward. –  kalina Jan 14 '13 at 16:00
    
@kalina When I set cl_forwardspeed to 10 the player indeed moved very very slowly. I think the problem is what you said, there is a maximum speed limit. How do I change maximum speed? There was a sv_maxspeed variable in Quake 1, but it doesn't work in Quake 2. –  hkBattousai Jan 14 '13 at 20:30
    
Don't think you can - as you said the variable isn't present in Quake 2. –  kalina Jan 14 '13 at 20:37
    
From what I read sv_maxspeed only works on hosted servers but not on local games. –  Philipp Jan 15 '13 at 9:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.