Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently started God of War2 on PS3.
But I got stuck because of a rendering issue after I first entered temple of lahkesis. Just after I came on my flying horse from somewhere.

I cannot give image here as I have 1 rating.

But its a place where I have to keep a dead body on a button that opens one of the gates and then pull a lever to open second consecutive gate. I am suppose to go in the door but the graphics are broken. If I go there I fall into infinity and die. Any work around. I tried re-loading the game but it doesn't work and unfortunately I was saving every check-point at one place so I cannot go a little back and try again.

My friend is playing same game from other profile it worked for him. Even for me, when I first came it was all good but I died once. But after I restarted rendering was broken.

share|improve this question
2  
I had a similar problem when I was playing the PS2 version, try running back the way you came, the game will try to stream the level data (you might see the game pause to load), after running a bit back, return to where the game glitched, this might solve your issue –  JohnoBoy Jan 16 '13 at 9:28
    
@JohnoBoy's suggestion is good - the GoW games often hid load times by keeping the player in one place for a while (i.e. spawning lots of enemies!) or by walking through simple rooms and corridors. Any of those around that might trigger the data to reload? –  Alex Jan 16 '13 at 9:55
    
@JonnyBoy: Sounds cool. But the funny part is the place where I am currently at, there is no way to go back. I just came flying from somewhere to this place :P Any other work around? –  Shadow Jan 17 '13 at 1:26
    
@JohnoBoy: Your suggestion worked. If you will add it as an answer I can accept it. –  Shadow Jan 22 '13 at 19:20
    
Glad to hear. I posted this as an answer. –  JohnoBoy Jan 22 '13 at 21:40
add comment

1 Answer

up vote 1 down vote accepted

Try running back the way you came, after running a bit back, the game will eventually try to stream the level data (you might see the game pause to load), after a certain distance (or seeing the loading prompt) return to where the game glitched, this should solve your issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.