Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm going through Fable 3 and am doing a quest where I need to bring a guy from the main city (forget the name) to Driftwood. I've gotten to Driftwood, but within a couple minutes of walking through there my game consistently freezes. I hear a brief beep, occasionally the graphics get a little distorted, and then it just stops. This has now happened to me around 5 times, and it's consistent.

I've tried leaving and then returning to Driftwood, but it doesn't seem to help. I've also seen the crash happen when in the sanctuary (went there to attempt to jump to a different quest).

Has anyone run into this? Any ideas how to fix it?

share|improve this question
1  
I have not had any issues with Driftwood. I searched around and haven't found anything online either. Have you checked your disc for dirt or scratches maybe and tried cleaning it? Sounds like an issue with just that location so maybe it's the data. I'm running mine off the hard drive install, not sure if that's an option for you or not, but it may be worth a try as well. –  Doozer Blake Nov 5 '10 at 12:26
    
Disk isn't involved, as I have the game installed to disk. A friend of mine said the crash I'm seeing is similar to something he saw in Fallout 3 shortly before his xbox red ringed, so I'm a bit worried it's the system and not the game. –  Herms Nov 5 '10 at 16:55
    
xbox jus red ringed, so I'm guessing it wasn't a problem with Fable. Oh well. –  Herms Nov 6 '10 at 23:33
1  
@Herms You may want to answer your question as something like <q>"The problem turned out to be my Xbox 360 red ringing."</q> so this question will appear answered. I hope you got it fixed! –  CyberSkull Nov 10 '11 at 15:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.