Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Originally I ran StarCraft 2 on Windows Vista and everything worked fine.

A couple of months ago, however, I upgraded my PC to Windows 8. I run Starcraft 2 without any issues, but replays now are working very bad; after 2-3 minutes of playing (usually on x2, x4, x8 speed) it hangs for a while. During the hang-time music is still playing, but the game in fact is frozen. It restores in 30-40~ seconds and after a while it hangs again.

How can I solve this problem?

However, upon my upgrading to windows 8 I didn't re-install StarCraft 2. Do I need to?

share|improve this question
If you upgraded Windows Vista to Windows 8 then you should have had to reinstall ALL your applications since NONE of your applications are transfered over. Its also entirely possible this is a hardware issue and has nothing to do with Windows 8 – Ramhound Jan 28 '13 at 15:16

You should

a) Reinstall SC2
b) Contact the blizzard support via ticket

Often times they can help you regardless of whether it is a known issue or not. (You can write a ticket from your Account and can also check, if there is a similar problem there)

share|improve this answer
Ok, thanks, will try to submit report to blizzard and see if/what they recommend. – Budda Feb 4 '13 at 2:48

What helped is full Windows 8 re-installation. Potentially, problem could be that my previous version of windows was 'developer edition'. I installed the standard one and now everything is fine. Don't know what exactly happened, may be it just pulled better drivers for my SSD...

share|improve this answer
up vote 0 down vote accepted

In fact problem was not with Windows version. Problem was in SSD. Due to some reasons game perform some disk loading operations and because of particular SSD model it become slower and slower. I've observed similar problems with other applications.

Replacement of SSD (M500 model instead of V4) resolved problem IN FULL.

See more details on that here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.