Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am playing Age of Empires on Windows 8, through my Mac with Parallels, and I am thinking that it is either a problem with Windows 8 or Parallels because it didn't happen on my home computer running Windows 7. Any advice? I'm using a MacBook with Retina display 15in and Parallels 8, running Windows 8.

share|improve this question
Do you have a controller plugged in? Some games "helpfully" hide my mouse cursor when I leave my controller plugged in, even if I'm not using the controller – Ben Brocka Feb 5 '13 at 20:00
AoE 2 doesn't support controllers so I doubt that is the case here. – jw013 Feb 5 '13 at 20:12
Yeah I'm sure that controllers would do that, but no I don't have one :/ – Harrison Feb 5 '13 at 20:14
Pfft, "using a mouse for a strategy game". Try playing Dwarf Fortress. – user1337 Feb 6 '13 at 16:02
Turns out Windows 8 doesn't really like Age of Empires, I just installed Windows 7 and it works great! – Harrison Feb 6 '13 at 22:01

Some games I play on the PC offer "Custom Cursor" settings, which for some reason always hides my mouse. I have to go into options and turn it off. It's a pain, because the cursor is invisible, and you have to watch for buttons to change slightly most of the time.

share|improve this answer

you sure the mouse isn't just flickering real fast, either way, could be your graphics card/drivers?, my computer is Windows 7 and when i load the game up the main menu is really screwy and when i play a map, some things in the map have weird pink pixels around them, it's the reason why i've stopped playing it and got Age of Empires 3 cause it works slightly better (apart from the fact that when i complete all objectives it doesn't end the mission, sometimes have to leave the game running for an hour before the flag is detected)

share|improve this answer

Try right-clicking the game start up icon and selecting properties. In the 'Target' box you get the string that launches the game. Immediately after that type the word normalmouse and press apply. Try it then.

share|improve this answer

Try running in compatibility mode.

Right click the game icon and select properties. Now select the compatibility tab and select windows XP service pack 2. This should help Windows 8 users.

share|improve this answer

I had the same issue with a disappearing mouse cursor. Turning off EVGA precision X16 solved the problem for me.

share|improve this answer

The normalmouse switch fixed it for me. Example below.

"C:\Program Files\Microsoft Games\Age of Empires II\empires2.exe" normalmouse

share|improve this answer

If resolution is changed(increased) in options during gameplay it helps in displaying the arrow cursor.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.