Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My configuration: Mac machine using Win 7 with Bootcamp, ATI Radeon HD 6490m display adapter. And the game runs horribly, compared to what I see for consoles.

I tried different things, most notably installing catalyst control center and unchecking "Application Settings" for Anti-Aliasing and Anisotropic filtering in attempt to wake up the video card and boost the performance (was reading in some forums that the video card is running in idle speeds, that is why the frame drops).

No visible improvement of frame rate (especially Undead Burg, and other areas with fires, Blighttown is just awful).

Do you know any tricks?

share|improve this question
Sounds like your video card meets the minimum spec. Hard to tell if it meets the other requirements, though. – Frank Feb 5 '13 at 21:16
I'm also interested in this one. After upgrading to Win7, Dark Souls was the only game that lost FPS. Fiddling with DSFix (Linked in Shykin's mod) settings doesn't seem to help. The game's ported very poorly, in general, so without some very powerful hardware and/or a number of tweaks, it will always have major FPS drops in Undead Burg and Blighttown - the other areas are thankfully more merciful. – Pvt. Grichmann Feb 6 '13 at 8:15
the only explanation i can come up with is the fact that the game does not have loading screens of any kind unless you quicktravel. and im fairly positive that undeadburg and blighttown are located geographically above/below other areas in the game, so it is probably possible that the game is having frame rate issues due to the increased activity in those areas. then again, this is just a guess at the general issue – Ravekner Feb 6 '13 at 10:05
DSFix actually made things a lot worse as framerate... But there are many factors, so probably the most important is that it is not helpful. – Danail Feb 6 '13 at 11:00
@Pvt.Grichmann, you say "after upgrading to Win7" - does this mean that on windows Vista (or XP) it was performing better? – Danail Feb 6 '13 at 11:03

Dark souls has a mod/fix that allows you to run the game at a higher framerate/resolution than it was built for. However the same mod also can increase performance if you leave the resolution the same as it was (1024x768).

The mod is placed in the same place as the exe I believe. It comes with a readme. I'd like to point out the on the console blighttown and undead burg had a tendency to lag slightly.

share|improve this answer
I've tried before with DSFix 2.0, and the framerate was worse than normal installation. I'll try again - with 2.0, and some older version (1.4 maybe), and will see how the game handles it. – Danail Feb 6 '13 at 16:07

Use skyrim ENB with ENBoost. (it actually works)

1) Unpack the d3d9.dll, enbseries.ini and enbhost.exe out of's injectorversion folder and enblocal.ini out of the ENBoost's folder corresponding to your graphics card manufacturer into DATA folder of the game.

2) Be sure to disable any kind of AA, including the SMAA and FXAA in DSFix.

3) For optimal performance changing the priority of DARKSOULS.exe in Windows Task Manager is suggested.

It runs constant 30fps in blighttown on laptop with i3 1.8ghz, Intel HD Graphics 4000 and 6gb of ram. (DSfix 900x720, ENBoost, High priority)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.