Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

This question already has an answer here:

This is pretty much a similar case to How do I stop the launcher bringing up the UAC prompt every time? but under Windows 8.

I tried to go through the steps and install the shims for the launcher, but somehow it doesn't seem to work. So the problem I'm facing is that I need to be present whenever my son wants to run the game and provide the admin password. I don't want to give him admin rights across the board, but grant him rights to run the Launcher.exe Is that at all possible under Windows 8 64-bit?

P.S. I have tried to contact Bioware's support, just to find that they don't know what to do...

share|improve this question

marked as duplicate by Mufasa, kalina, 3ventic, Billy Mailman, Frank Feb 6 at 16:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    

2 Answers 2

Ok, I didn't let go and approached it again, and... I think I did it :)

Here is how it worked for me:

  1. Installed ADK as per link provided by Matthew Read.
  2. Installed the database server from the installation options.
  3. Ran Compatibility Administrator (32-bit) (In Admin mode)
  4. In the column on the left, on the bottom selected New Database.
  5. The top bar - selected 'Fix'
  6. Got a window named 'Create new ApplicationFix'
  7. Used mu own names in the first 2 fields, in the third one pointed to the location of Launcher.exe, pressed 'Next'
  8. Did nothing in the 'Compatibility Modes' window, pressed 'Next'
  9. In 'Compatibility Fixes' window scrolled down and ticked 'Force Admin Access'
  10. Pressed 'Test Run' - Launcher ran without asking for admin password (yes!), pressed 'Next'
  11. In 'Matching Information' window only left 'File Description', 'Company Name'and 'Product Name' ticked, pressed 'Finish'

I am not sure if the following 2 steps were necessary (especially 1), but I performed them...

  1. Top bar - pressed Save and saved the database in the same folder as Launcher.exe
  2. Top menu, from 'File' pull-down selected 'Install'

I only did all this like 20 minutes ago, but managed to run the game twice in the meantime, so hope this works for others as well

share|improve this answer

That version of the ACT, 5.6, doesn't support Windows 8. You need 6.0 which comes from the Windows 8 ADK: http://www.microsoft.com/en-ca/download/details.aspx?id=30652

If you choose the install option it will let you choose to select only the ACT. I don't know the exact steps for using it since I don't have Windows 8, but it should be very similar to the process for 5.6. There is also online help for it here: http://technet.microsoft.com/en-us/library/hh825181.aspx

share|improve this answer
    
Hi, I installed the ADK, but it looks and acts nowhere near the Microsoft Application Compatibility Toolkit 5.6; also required me to set up an SQL server to keep compatibility databases, and to be honest it's way too complicated for me. I appreciate your help though... –  dalogrus Feb 20 '13 at 23:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.