Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

All right, let me tell you what I know so far.

  1. Enabling Vsync and Triple Buffering may help, but my AMD VISION menu doesn't allow me to do that.
  2. This game played PERFECTLY on this laptop before, but suddenly started becoming choppy.
  3. My video card isn't bad, other games work fine (With the exception of TF2 which gets the same framerate)
  4. I don't have a virus.
  5. My specs are:
    • Processor: AMD E2-1800 APU with Radeon HD graphics 1.70 GHz
    • RAM: 4.00 GB
    • OS: 64-bit Windows 8

Someone please help. I've been everywhere.

share|improve this question
    
First things first, are your video card drivers up to date? If not, update them. –  Kevin Mar 16 '13 at 2:29
    
Yes, that's the first thing I did when I found out about my little problem. –  ScythianSteppes Mar 16 '13 at 2:36
    
Ok it's down to guessing then. Have you tried uninstalling the game and then reinstalling it? It's possible something messed up the files. –  Kevin Mar 16 '13 at 2:40
    
I've tried uninstalling and re-installing, validating files, and defragging. –  ScythianSteppes Mar 16 '13 at 2:49
    
I can hardly imagine you didn't, but have you tried running as administrator, compatibility mode, disable display scaling? –  Kevin Mar 16 '13 at 2:56
show 8 more comments

2 Answers

Did they patch it recently? It could be something they did to the game, I've had that problem with Chivalry. I have to turn all of the video options to low or off in order to be able to play that game now. Try tweaking any in-game settings they give you to see if it will improve performance.

You can also try setting your desktop background to black - this is a trick I picked up back in the mmo days. If you have a large file as your desktop bg it requires more resources from your computer.

share|improve this answer
add comment

I had this issue along with really bizarre graphics.

I solved it by:

  1. Right click on desktop, choose your graphics card control panel

  2. Tell it to use integrated graphics instead of your normal graphics card

Or, simply tell your graphics cards not to use Bilinear nor Trilinear filtering.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.