Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I was trying to play on 11.CBGA.ME (Super Craft Brothers (server 11)) and I got a client too old error, so I checked the version and it was 1.4.7, The newest one 1.5.0 (Redstone update), so why isn't Tekkit updating to the newest client?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

They have to wait for all of the mods that they include in the pack to be updated.

Some mods, like Forge, use the prerelease to update -- but some don't. For some mods, the authors just aren't paying attention. And for some mods, updating is actually hard, and they weren't able to get it functioning by release day.

Expect a list of "mods that we're waiting for" to come out soon.

share|improve this answer
    
It should take a decently long time this time because of the overhauled redstone code in 1.5, so don't expect too much too soon. –  Jochem Mar 16 '13 at 21:55

The long and short of it is that Tekkit is a massive collection of mods, All of which will be written for 1.4.7 (if you're using Tekkit Lite), Before you can use 1.5.0 with Tekkit we'll need to wait until the mod authors have re-written their mods to work with 1.5.0.

Probably the best thing to do in your case would be to get in touch with an Administrator at your regular server and ask which version you need to be using. Then i'd suggest clearing your cache on the launcher and starting fresh.

For the latest news and updates on Tekkit keep checking the official TechnicPack site news - http://technicpack.net/news (Includes Tekkit news, same people for Technic and Tekkit)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.