Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a problem with Fallout 3 GOTY and with Fallout : New Vegas, both Steam version. Fallout 3 GOTY crashes as soon as I try to create a New game, while Fallout : New Vegas crashes immediately after first video. No other messages than the generic Windows 'Application stops working' dialog.

I have tried many things:

  • Check game steam cache
  • Re-downloaded the whole game content two times(!)
  • Set lowest/highest default settings
  • Start in window/full screen mode
  • Change different resolutions

I have no mods installed.

My config: AMD X3 720 - XFX ATI HD 4770 - 4 GB RAM - Windows 7 32-bit

UPDATE: I tried also the following things but STILL no result

  • Updated drivers to latest 10.10 from ATI/AMD
  • Re-installed DirectX
  • Set Compatibility Mode to Fallout3.exe and FalloutLauncher.exe both Windows XP SP3 and Windows Vista SP2
  • Changed Fallout3.exe and FalloutLauncher.exe to disable Visual Themes, Desktop Composition, DPI settings and Run as Administrator
  • Game for Windows LIVE Disabler

more updates

  • Disabled all 3rd parties services and aborted most of Windows processes
  • Checked GPU BIOS version, is the last

FIRST BOUNTY Bounty ended without a working solution. Bounty points have been assigned to Oak, that suggested to install Windows XP in dual boot. Question remains open, because I would prefer playing it in Windows 7 in the future, if possible.

UPDATE I cannot believe it! I bought Fallout:New Vegas on Steam sales and SAME problem!

share|improve this question
5  
Welcome to a Bethsada game engine, and the buggy mess that it is. –  Zoredache Nov 15 '10 at 20:06
    
is it possible that you can link a screenshot of the "Application stops working"-Message? –  Iceag Nov 22 '10 at 7:58
add comment

10 Answers 10

up vote 10 down vote accepted

Yes, yes, yes! Due to the addition of the Fallout New Vegas issue, I was able to Google that and find this .dll, which proved to be helpful in solving the issue.

Just download the d3d9.dll linked here: Alternate D3D9 Fix for ATI.

Thanks a ton to the author of this .dll. I can confirm that it fixed the problem with both Fallout games and hope it can solve the same problem for other gamers too.

Now I can jump into the Fallout world again.

share|improve this answer
add comment

A few ideas:

  • Install latest AMD drivers
  • Reinstall latest DirectX
  • I remember reading about problems with some tools from the graphics card manufacturers, try deinstalling those, if you have any.
  • Try disabling Aero

You should also try searching the official forums, if anyone with a similar configuration has the same problem.

share|improve this answer
2  
+1 also try unplugging/disabling every non-essential piece of hardware from your machine (speakers, everything USB including the mouse if you have a spare PS/2-mouse, every addon card but your graphics card, etc.), and disable all non-essential software. There have been some wierd hardware-related crashes in a lot of games in the past (not just Fallout 3 specifically) which only occur with some esoteric combination of hardware/software. If that works, enable things one-by-one until it crashes again to determine the root cause, and post back here to let us know. –  BlueRaja - Danny Pflughoeft Nov 15 '10 at 16:55
    
thank for your suggestions, tried all but game still crashes –  Drake Nov 17 '10 at 8:48
add comment

Unlike the others here I don't really have a supposed solution, but instead a possible work-around(s), which I hope can help. I have listed 3 options below, but the bolded sentence in option 2 is the one which will probably work best.

Option 1: upgrade to 64-bit

Change your operating system to Windows 7 64-bit. Of course, nothing guarantees it will then work, but it just might - and I personally see no harm in such an upgrade (at least, not much harm).

You don't have to purchase Windows 7 again, all regular Windows 7 editions should include both the 32-bit and the 64-bit varieties. In today's world 64-bit is in general preferable, in my opinion, especially given your amount of RAM. There's no direct upgrade path from Windows 7 32-bit to 64-bit, but you can use the Windows Easy Transfer tool, which is pretty easy.

Option 2: play it in Windows XP

Windows 7 is not officially supported by Fallout 3, but Windows XP is, so I guess an obvious solution is to try and run it with XP! This gives you the following options:

  1. Run Windows XP on an emulator. Many modern emulators don't critically degrade performance, just make sure you use an emulator which supports 3D acceleration. Windows XP Mode, for example, available for free for Windows 7 Professional and Ultimate, does not support acceleration as far as I know. Instead, try getting the open-source VirtualBox or the free VMWare Player, both of which should theoretically support the game, especially if you have a powerful machine. Notice that you need to have a valid XP installation - disc and serial number - to install it on the "guest" OS (the one being emulated).

  2. Dual-boot Windows XP with your current operating system. This is probably the most fail-safe direction you can take to play the game. It requires some effort but there are plenty of guides available online on how to dual-boot, shouldn't be that big of a problem if you're keen on playing this great game. Again, you need a valid XP for that, but in that case success is basically guaranteed.

Be aware that if you use any of the above solutions, you would need to install Steam on that Windows XP as well, but that shouldn't be a problem.

Options 3: sue the bastards

Well I guess you should only pick this if you happen to have an expensive lawyer which isn't paid by the hour, but you can at least complain to Valve that the Steam store page is misleading: it only says XP/Vista is a minimum requirement, and does not explicitly say Windows 7 is unsupported, compared with the Doom 3 page, for example.

share|improve this answer
    
Thank you for the detailed answer. For sure reinstalling OS is an option but I would like to leave it as the last resource, because it will take me a lot of hours to do all backups about games/savegames, etc. Installing Windows XP on an emulator is not an option, because I would like running Fallout 3 at max details and I have also some re-textured mods to apply. Installing Windows XP in dual-boot is a good suggestion, I could try it. –  Drake Nov 22 '10 at 9:52
    
@Drake I agree dual-booting is probably the best option from those I've listed (hence using bold). There are tons of tutorials online on doing that - here's one that looks nice - and I think that in terms of time investment it won't be that bad, surely less than the time you already spent trying to get it to work... –  Oak Nov 22 '10 at 10:20
2  
OEM versions do not include both 32 and 64 bit - at least not Dell ones. –  Macha Nov 22 '10 at 22:16
    
Bounty ended without a working solution. Bounty points have been assigned to you, for the dual boot suggestion. Question remains open, because I would prefer playing it in Windows 7 in the future, if possible. –  Drake Nov 24 '10 at 20:33
add comment

If your running standard hardware with up-to-date drivers, try disabling all background programs and non-essential programs (including your virus scanner, which might try to read the same memory as the game or play with some files it tries to load).

Press WINKEY + R, type msconfig and enter In the general tab, hit "Selective Startup" and uncheck "Load Startup Items" Go to the Services tab and press "Hide All Microsoft Services" then presss "Disable All" Press Ok, then restart when prompted. Try the game again without any third party programs or services running.

To restore, simply go back to msconfig and select "Normal Startup"

share|improve this answer
    
Thank you. I tried disable all 3rd party services. Same problem, crash after few seconds I have pressed New game –  Drake Nov 19 '10 at 20:18
add comment

Things that have worked in the past:

  • Flashing videocard bios

  • making sure that you are only running 2 cores on your processor. What you need to do is try to start the game, and then press ctrl+alt+del and choose the process. In XP, I know you can simply right click the process and choose 'Set Affinity'. Not sure in 7. In any case, previous patches of Fallout 3 seem to have broken Quad Core support, and the X3 has 3 active cores, so I wouldn't be surprised if that was the problem.

Also, before you go on to flash the gfx bios, try disabling the third core first :D

share|improve this answer
    
I tried setting 2 cores with affinity, but crashes happen as usual. Also there are no recent GPU bios for my card. –  Drake Nov 19 '10 at 20:00
add comment

Edit the fallout.ini in the My Documents/My Games/Fallout 3 folder and change the following settings from their current values to those shown below:

bUseThreadedAI=1

and

iNumHWThreads=2

This will fix the problems relating to fallout 3 crashes on some multicore systems.

Source

I had problems with Fallout 3 crashing on my Core 2 Quad and this fixed it. Someone else has suggested "Set Affinity" and I don't know if that works, but this did for me.

share|improve this answer
    
good attempt, but same as before :( –  Drake Nov 21 '10 at 11:19
add comment

Here's an idea that might help: try disabling your audio when running the game and see if the problem goes away. Windows 7 and Windows Vista both completely changed the audio driver model, pretty much breaking all the games that expected audio hardware acceleration, and if Fallout 3 is looking for that support that could easily cause the fault you're describing. I remember having a similar problem under Vista; check out the following web site for some advice:

http://www.unigamesity.com/how-to-fix-fallout-3-lock-ups-and-crashes/

share|improve this answer
    
I tried disabling "Windows Audio" service, but Fallout 3 said me that cannot run withoud and audio device –  Drake Nov 21 '10 at 14:26
    
What sound card do you have? Does it have any configuration tool that will let you disable EAX emulation or other hardware emulation? If not, I believe you can disable audio in the game altogether by editing the FALLOUT.INI file (found in your Documents\My Games\Fallout3 folder) and changing the line that reads "bEnableAudio=1" to "bEnableAudio=0" under the "[Audio]" section of properties. Give that a try and see if it fixes the crashing. If so, it's an audio issue for sure and then it's just a matter of figuring out how to get things configured. –  Phileosophos Nov 22 '10 at 0:47
    
good try, but unfortunately also disabling audio with bEnableAudio didn't solve –  Drake Nov 24 '10 at 20:30
    
Dang. Sorry, Drake, I really thought the audio would turn out to be the problem. –  Phileosophos Nov 27 '10 at 3:16
add comment

I remember trying to play Fallout 3, and found that adding it to a list of exceptions in the ffdshow codec's audio settings seemed to have a positive impact. If you search your programs menu for "FFDshow Audio Decoder", then add "fallout3.exe" to the list of files not to use ffdshow in - you may have similar success.

share|improve this answer
    
Thank you, I also read about it. I tried to add exclusion both for audio and video (it was already there) but same problem. –  Drake Nov 21 '10 at 18:06
    
Ok, sorry that wasn't of more help. I also remember having to uninstall some bluetooth-related component on my laptop, but I can't recall the name of it. If you've got anything like that on your system perhaps give it a try? –  TZHX Nov 21 '10 at 19:17
    
No bluetooth. I have a Microsoft headset, webcam and gamepad and Logitech mouse. I tried kill all related process but no way. –  Drake Nov 22 '10 at 9:54
    
Possibly try pruning some superfluos services as well? Run services.msc –  TZHX Nov 22 '10 at 18:42
add comment

I'm having the same problem and it's now 2012 running on Windows 7... I've tried every single fix online that I have found so far with no luck accept for running it in an emulator as I do have all Windows Disks from 3.11 up so maybe I can find something it'll work on.

Sorry I don't have a better answer but the emulator route seems to be the best one to take for those in the same boat as us, it's not as hard or risky as dual-booting your system which is fine too if you know what you're doing.

share|improve this answer
add comment

I started up Fallout 3 GOTY this past weekend and was having issues getting it to run. None of these answers worked for me so I tried a simple approach. I disabled my 2nd monitor and made Fallout 3 play in "windowed" mode. It runs perfectly so far, no crashes at all.

  • you can disable/enable your 2nd monitor at will by right clicking your background, then clicking screen resolution. Using the multiple displays dropbox, select "show desktop only on 1" or "show desktop only on 2" depending which screen you wanna use.

  • you can easily make Fallout 3 work in "windowed" mode by going into settings before clicking play at the launcher screen.

You may have to get used to playing the game at half your screen, but it may be worth it to some.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.