Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

ok so when i'm ingame (fullscreen) when I hold the right mouse button to zoom in with the scope on a weapon and then move the mouse to align it with a target, the screen just flips 90° in any direction so I need to find my bearings again and align it up again.

I got the problem with:

  • Alien vs Predator
  • Fallout 3
  • Fallout New Vegas
  • Medal of Honor 2010

but i don't have it with any of the Call of Duty games or Singularity.

So it is not a hardware problem. I also tried:

  • swapping my mouse
  • updating my gfx card
  • switching from hold right mouse to toggle

but nothing helps.

Any idea what would be causing this?

share|improve this question

2 Answers 2

up vote 5 down vote accepted

I would guess that this is caused by a tool that came with your mouse that allows you to define custom actions for you mouse buttons. Try to find out if you have anything like that installed and deactivate it.

share|improve this answer
    
Might also be the graphics driver. Some drivers install tools that allow you to set hotkeys for actions like "turn screen 90°", though doing that for the mouse seems wierd. –  dbemerlin Nov 17 '10 at 11:48
    
yep that fixed the problem: windows motions for touch screen. although fallout still acts strange when right clicking in a menu, but that not very annoying. thx a lot :) –  Berty Nov 22 '10 at 20:44
1  
@Berty I have the same problem. Where can I check if I have "windows motions for touch screen" installed or find the settings for it? –  user8468 Apr 9 '11 at 11:47
    
I thought I fixed it, but it didn't, still haven't found an answer, sorry :( –  Berty Apr 19 '11 at 16:21

I'v seen this problem in several games, where the camera angle is controlled by the mouse, and the right mouse button causes the angle to jump suddenly. I've never found a satisfactory explanation for the effect, though I've always been able to solve it by setting the program to run in compatibility mode. If I set the game to run in compatibility mode (which can be set by right clicking on the program [the actual program, not the launcher or a shortcut] selecting properties> selecting "compatibility" tab> changing the compatibility to Windows XP) then the effect goes away.

share|improve this answer
    
nice, i'll try, hope it doesn't drag down the framerate though –  Berty Aug 6 '11 at 8:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.