Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a pretty good gaming computer and I am having trouble playing Feed the Beast. This problem has happened pretty recently. The change wasn't sudden but it deteriorated very quickly.

I am on a single player world and there is block lag. I cannot pick up items on the ground, I have trouble breaking blocks, and when I right-click on machines it takes 2-3 seconds before I see the interface. Machines take way longer than they are supposed to.

My FPS is stable at 120 and the game is smooth, but sometimes I teleport back to where I was 5 seconds ago. The world I play on is pretty small. None of these problems affect me on regular Minecraft or on other FTB worlds I have created. I am currently running the mindcrack pack. I have tried installing Optifine but it doesn't help. I don't have any windows or programs open when I play.

I have 64 bit Java and am using 4 out of 8GB RAM to run the game. I have tried reinstalling the game and think that the problem is with the actual world.

share|improve this question
1  
For clarification this is a "blockLag" problem not a FPS problem –  user46373 Apr 5 '13 at 0:44
3  
There are a couple million things that could be causing this. Are you noticing anything weird in the console and are there any machines in particular this happens with? The fact that it only happens in one world leads me to believe that it's not a RAM issue or anything of that nature, but rather, related to something in the world. Or perhaps the switch from Rei's caused some weirdness. –  Unionhawk Apr 5 '13 at 0:45
1  
@jeffreylin_ 4 GB should be more than enough. –  Unionhawk Apr 5 '13 at 0:45
1  
1  
Do you have any complex redstone circuits or constantly-running complex machines, or lots of items moving around all the time? The problem is almost certainly your world, but you haven't told us anything about it. Are you in the habit of moving through multiple Ages a lot? –  SevenSidedDie Apr 5 '13 at 0:50

3 Answers 3

A ton of the mods in FTB are very poorly coded (eg. to check if solar-panels can see sun, they use the dumbest algorithm possible: a for loop that checks every y-value above it for blocks every freakin' server tick).

To test if this is your issue, remove all world anchors (and all similar blocks that keep chunks loaded) and go far away from your main-base to someplace you've never been (so that everything you've built becomes unloaded). If the "lag" stops, then the problem is most likely a CPU-hungry mod.

There's not much you can do about CPU-hungry mods except turn them off, or (in single-player only) just promise yourself not to use blocks from the laggy-mods. Because it's a CPU-issue, reducing the graphics won't help. You could try increasing the process priority, but that likely won't help much, and could cause stability problems.

Unfortunately, there's no ultimate-list of laggy mods that I know of, and the list changes with every version anyways. Check the FTB forums, and see which mods most server-administrators are currently disabling, and why.

share|improve this answer
1  
I know there was something about advanced solar panels complaining in the logs 32 times per tick if they don't have a place to send power, or something stupid like that too. There's all kinds of things like that... –  Unionhawk Apr 5 '13 at 3:27

You should definitely try reducing video quality along with other things that help kill CPU.. i.e. render dist, fancy graphics, lighting. Its always better to go for 'function over form' settings.

share|improve this answer

You should wait and let your world load then Block Lag will be reduced

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.