Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my PC, Bioshock infinite doesn't launch properly. 9 out of 10 times it minimizes itself on launching. Repeatedly attempts may lead to successful launch, but even after that after 1-2 hours it automatically reverts to Desktop(Game still runs in background though). I have disabled my Windows Defender. This is my configuration.

Windows 7 64 bit
Intel Core i5 2.3GHz
Geforce GT 525M

Thanks in advance

share|improve this question
Hi @Yogi. When the game minimizes (at start, or during play), can you maximize it and continue playing? – EBongo Apr 6 '13 at 11:43
up vote 0 down vote accepted

Search and destroy for offending programs

For debugging this type of problem, I would first check other programs running in the background. Some applications like real time virus detection, anticheat software, or "updater" applications may be trying to come to the front. You should be able to go into task manager (accessible when you press CTRL+ALT+DELETE) and kill most other applications. That's sort of brute force, but if you find the process that's causing you trouble by process of elimination, there may be a more graceful way of shutting it off from the application itself in the future.

It may be that Windows Defender is still your problem, even though you "disabled" it. One person here suggests updating to the latest version. Others have seen this problem with IM clients, and of course there is always Spyware. Here's a video with a walkthrough on killing potentially offending background tasks, though you may have to hunt a little hard than he did to find the process which is causing you trouble.

If you suspect Spyware, I recommend MalwareBytes and Microsoft Security Essentials.

Download latest graphics drivers

This behavior falls into the category of "graphics isssue". For any such issue, it's always a good idea to download latest drivers.

Try an autohotkey or similar script

You can use functions of windows to force your Bioshock window to always on top. A script will make it easier for you to do so, via hotkeys. You can download one such script here.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.