Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am using Single Player Commands to assist me while making a map. I am trying to use the /butcher command (this kills all mobs near the player), but I keep getting this error:

java.lang.StackOverflowError: null

I am not sure what the problem is.

Also my computer specifications can be found here.

share|improve this question
    
Are you running Minecraft with the default amount of RAM? If so, you should try increasing it and see what that does for you. –  MBraedley Apr 8 '13 at 3:48
    
I have 4GB allocated to Minecraft. I have 8GB of ram. –  user47129 Apr 8 '13 at 3:54
    
Is any more information included in this error? –  mrfishie Apr 8 '13 at 4:03
    
Unfortunately no. Here is a screenshot to show: i.imgur.com/2q2NL4k.png –  user47129 Apr 8 '13 at 4:08
    
That's probably too much RAM, and certainly way more than Minecraft usually needs. You might be starving other processes for memory, but I don't see how that could cause a stack overflow… –  SevenSidedDie Apr 8 '13 at 4:10

3 Answers 3

up vote 1 down vote accepted

There are a few things you can try, here is what I would try if I were in your shoes:

Make sure that the versions of your mods and minecraft match up - are you playing on Minecraft v1.5.0 but using World Edit 1.5.1?

If you are using the proper version of everything, try these commands and seeing if you get the same error (please don't be surprised if any of these spit out an unknown command error to you) :

//butcher

/butcher 50

//butcher 50

Where the 50 represents the radius around you, meaning any mobs within a 50 block radius will be killed.

If that still doesn't work, try forceupdating your minecraft, then installing SinglePlayerCommands on your clean minecraft.jar.

There might be other mods, such as ones that add in new blocks, or even mobs, which might be interfering with you. So make sure to check (that if you are using these other mods) that you have compatible versions.

share|improve this answer

Try to force update Minecraft, it's a bug with a Java loop. If Minecraft works, make sure, that you downloaded the latest (1.5.2) singleplayer commands (automated installation is better). If it doesn't works, try to install manually (and delete the Meta-inf)!

share|improve this answer
2  
"It's a bug with a Java loop": that sounds like you're referring to a known bug, that is maybe documented somewhere? If so, could you provide a link, or more background? Just something so that a reader can better judge the veracity of this answer. –  SevenSidedDie May 14 '13 at 17:50

The Stack Overflow error is caused when the program goes out of the bounds of an array (a type of storage that can store multiple values all alongside each other). Since each array has a specific length, what has happened is that Single Player Commands has gone over the limit of one of its arrays.

The cause of this could be because you are trying to slaughter too many animals at the same time, so try just butchering mobs in a small area at the beginning and see how that works out.

This command will do this for you:

//butcher 20

Which will destroy all animals in a radius of 20.

share|improve this answer
    
No, if you go out of bounds of an array you get an ArrayIndexOutOfBoundsException. StackOverflowExceptions are generally caused by a dodgy recursive method call or set of cyclical method calls causing the stack to overflow. –  JonK Dec 15 at 11:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.