Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Trying to play Trouble in Terrorist Town. Every time I join a server, the progress bar goes real quick through all the files, and I get "Missing map map/<mapname>". I tried downloading the map manually and placing it in the maps folder, but that still does not work, because none of the other models/LUA scripts get downloaded either.

This issue does not happen in other sourcemod games (eg. TF2), only Garry's Mod. Before a few updates ago, it used to work on on this same computer, with the same Internet connection.

What can I do to resolve this?

share|improve this question
    
I'm haveing the exact same problem and so is both of my friends with gmod –  user54930 Sep 7 '13 at 15:59
add comment

2 Answers

up vote 7 down vote accepted

Posting this question/answer here, since the solution doesn't appear to exist anywhere else (outside of my own steam forums post):

Apparently Garry's Mod uses Internet Explorer somehow for its "FastDL" downloading. If Internet Explorer can't connect to the internet for whatever reason, then Garry's Mod won't download anything.

In my case, IE was set to offline-mode. Setting it to online fixed the issue.


Other things you can try:

  • Make sure Options --> Multiplayer --> Download Custom Content is set to Allow All Custom Files From Server

  • Try adding the following lines to the bottom of your garry's mod config file, located at Steam\steamapps\<username>\garrysmod\garrysmod\cfg\config.cfg:

    cl_allowdownload 1
    cl_downloadfilter all
    download_debug 0
    sv_downloadurl ""
    
  • Verify the integrity of the game files. Within Steam: Library --> Garry's Mod --> Right Click --> Properties --> Local Files --> "Verify Integrity of Game Cache"

  • Try disabling your firewall/antivirus, or possibly other non-essential programs/services running.

  • Try deleting your maps, lua, addons, and cache folders in the garrysmod folder, located at Steam\steamapps\<username>\garrysmod\garrysmod. Then verify your cache again.

  • As a last resort, uninstall Garry's Mod completely and delete the garrysmod folder (which you'll have to do by hand, because there will be leftover files), then reinstall.

share|improve this answer
add comment

This is due to addon confliction. I recommend disabling all of them to play the server I'm afraid.

share|improve this answer
add comment

protected by Community Sep 7 '13 at 16:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.