Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm currently running Starcraft through wine version 1.4.1 on Ubuntu 13.04 Raring Ringtail. Most features of the game work just fine. However, when I play on battle.net, my keyboard seems to lose functionality. While I can chat just fine in a battle.net lobby, the moment I join a game lobby it all ends. Once the game starts, not only can I not chat with my teammates or taunt them, I can't move my screen with the arrow keys. I do believe some short cuts like a to attack still work.

So, has anyone gotten battle.net to work successfully with any other version of wine or by adding some kind of dll override?

share|improve this question
    
Try pressing alt a couple of times. I've gotten issues like this on Windows where the keyboard doesn't seem to work; it's just an alt+tab glitch. –  Decency May 9 '13 at 5:26
    
@Decency Unfortunately to get Battle.net working on Ubuntu, I had to disable the window manager from having control over the window using wine-config. This means the game's window shouldn't lose focus. Anyway, for the time being I'm using wine 0.9.14 since the other bugs that I haven't mentioned don't appear in that old version. –  Nil May 9 '13 at 5:30
    
It's not a solution, but maybe these informations will help: - I have this problem only in fullscreen (windowed mode works fine) - One time, when program was switching from battle.net game setup to Starcraft game lobby, system cursor showed up (for a second) and keyboard worked fine for the whole game.. It happened randomly and for the next game started through Battle.net (the same Starcraft process) problem occurred as usually. –  Adam Skobodzinski Jan 17 at 14:03
add comment

1 Answer

up vote 0 down vote accepted

I found a work around for all known and some unknown bugs in the game, though I'm not quite happy with the answer. An older version of wine, versin 0.9.14, seems to work perfectly with Starcraft. Using PlayOnlinux, I created a new wine prefix that uses wine 0.9.14 and then used the installer that I downloaded through blizzards website to install the game. With this solution I have full functionality of the keyboard and am able to chat with other players to their misfortune.

Still, newer versions of wine shouldn't lose functionality, this is definitely something that needs to be fixed. However, that's for AppDB and not gaming on stack exchange. For now, the work around to the bug is to use this earlier version of wine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.