Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

On trying to fire up any game in Steam, or Activate a Product on Steam, a popup will display stating "Scanning for Steam games updates.", and just sit there. It never does anything, and only offers a Cancel button (which sometimes is even disabled), which doesn't allow me to start the game from Steam.

I assume it's never going to stop, it's been going for minutes, so, is there a way around this, a way to fix this, or a way to disable this scan?

enter image description here

share|improve this question
    
I think this question goes too far from the main topic of this website. You really should write to Steam's support if you encounter a bug with Steam. –  BlaXpirit May 19 '13 at 13:18
4  
@BlaXpirit Steam is most decidedly on-topic for Arqade. It's a program that most gamers use, and I think we're pretty good experts on solving various issues that crop up. –  Frank May 19 '13 at 13:21
    
Any chance you can restart Steam? I've had similar issues, and that usually resolved them. –  Frank May 19 '13 at 13:22
    
@fbueckert Restart of Steam didn't work, but a reboot cleared it up. Thanks. /me hangs head in shame when I don't do the obvious. –  Doozer Blake May 19 '13 at 13:35
1  
Okay, now I was sitting here 2 minutes waiting for Steam to start because I just launched it, but it was already open in the background... –  NoneOfYourBusiness Jul 3 '13 at 18:03
add comment

5 Answers

up vote 8 down vote accepted

There are a few things you can try:

  • Restart Steam.
  • Reboot your Computer
  • Wait until its done.
  • Rename the file ClientRegistry.blob to ClientRegistry.bak. By default you should find this file under C:\Program Files (x86)\Steam. This will force steam to generate a new .blob file and might fix your problem.
  • Disable and exit steam-limiter if you have it
share|improve this answer
add comment

I've found that logging out (via change user) and logging in again fixed it for me

share|improve this answer
add comment

A solution that I have found is to go to steam>settings>account then click the "change" button next to beta participation and choose to participate. This works because the latest beta update fixes the problem.

share|improve this answer
add comment

It is sometimes sufficient to kill Steam.exe from the Task Manager, then launching it again.

share|improve this answer
add comment

Just click on the steam button on the top left corner and go online

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.