Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am playing HomeFront on the PC with all the latest updates from Steam and I have this problem where the changes I make in the graphics menu just before starting the game is not applied when I am playing the single player campaign. For example I have set the overall quality to "High" but it is not applied when I start the campaign. The options to change the video settings are grayed out when I am playing the campaign. I cant change the graphics quality whatever changes I make is not actually applied. I have googled out this problem but I have not found any solution to it. I don't know how to edit the .ini files in my config directories manually. I am at a bit of a loss here. Is there anything that can be done to resolve this problem?

My PC Specs by the way are - (Using the latest video/audio drivers):

  • Intel i5 3.2 Ghz
  • NVidia Geforce 650 GTX 1GBDDR5
  • 8 GB RAM
  • Windows 8 x64 Professional

If any more details are required please inform me.

share|improve this question
1  
Some games do not allow you to change graphics settings while actually playing the game. How do you know they're not getting applied? –  Frank Jun 3 '13 at 15:20
    
because I have started the game in "Very Low" settings and also in "Very High" settings. There is no difference in quality when using either of them. Not even a lag in "very High" to indicate that my computer cannot handle that setting. –  Sreyan Jun 3 '13 at 16:35
add comment

1 Answer

up vote 1 down vote accepted

You say you don't know how to edit the .ini files – unfortunately, to fix this you're going to have to learn. This is a common bug and the solution is to

  1. Make the changes directly to the INI files
  2. Set them read-only (right click → properties) so the changes won't be undone

You'll find the INI files in a Homefront folder under My Documents/My Games. They're just text files, so open them up in your favourite text editor (not a word processor like MS Word) and make the changes. You just find the field you want to change, then change whatever is after the = sign. The graphics settings you're looking for should all be under one section – sections are started with a title between square brakets (e.g., []). When you tweak the setting, remember to unset read-only first and set it read-only again after.

Homefront has multiple INI files for configuring different things. For graphics you'll want to look at GCEngine.ini. If you want to tweak mouse input, for example, you'll look instead at GCInput.ini.

It's easy once you actually start looking in the files, though it may take some time to read through all the fields and get an idea of what does what. The best way to learn is to just change things that look likely, and see what happens – that's how all the tweak guides were written. Just make backups of the original INIs before you start tweaking, and you have nothing to fear.

There are lots of discussions on INI tweaks for Homefront, such as this set of performance tweaks or this other Homefront tweak guide. Reading those will give you a sense of how and what to change.

As an alternative to a text editor, you can use a program like INI Settings Editor to give you a graphical interface to the INI sections and fields.

share|improve this answer
    
if I upload the file to dropbox and post the link over here can you have a look at it and tell me what fields exactly I have to change ? Also can you tell me from where I can learn how to edit .ini files like is there any site that describes the format ? –  Sreyan Jun 3 '13 at 18:08
    
@Sreyan The format is plain text, so once you open one and it should become obvious how to change things, though what to change will take some reading and guessing. I don't own a copy of Homefront, so I don't know what fields will change what. I'll add some how-to-edit info to the question though. –  SevenSidedDie Jun 3 '13 at 19:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.