Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've done a lot of google work to see if there is a solution to making my XBOX show up as an open nat. Still no luck. I have a Linksys WRT160N with v3.0.03 firmware.

Here is what I have done so far:

  1. Set XBOX to static IP
  2. Turned on DMZ and added the xbox static IP, saved config
  3. Turned off router, cable modem and xbox.
  4. Brought everything on-line - Result = Moderate NAT
  5. Went to single port forwarding and set up the following:

    88 TCP/UDP

    3074 TCP/UDP

    8602 TCP/UDP

    80 TCP/UDP

  6. Turned off everything, etc - Result = Moderate NAT

  7. Disabled single port forwarding and setup the following in port range

    87-89 TCP/UDP

    3073-3075 TCP/UDP

    8601-8603 TCP/UDP

    80 TCP/UDP

  8. Turned off, rinse repeat - Result = Moderate NAT

  9. Changed MTU to 1365 - No Change
  10. Made sure uPNP is on - No Change

Any Ideas??

share|improve this question
    
sure you have opened "incoming" ports and forwarded them to your XBox's static ip? –  DrFish Mar 4 '11 at 22:44
    
DMZ basically means that all incoming connections are redirected to the Xbox. If DMZ still shows as a NAT on your Xbox, then it's not a configuration issue. –  user56 May 8 '11 at 8:53
    
@Arda What if you have multiple PC/Xbox's within the DMZ (Z = Zone). You can't have all incoming connections redirected to 1 device. You still have to forward ports. The router would have no idea which device in the DMZ to forward said port to. –  mxmissile Jun 7 '11 at 21:26
    
@mxmissile Maybe if you're using a corporate firewall, but I doubt that's the case here. A DMZ is indeed a subnetwork in which, if used exactly like the specifications, ports may still need to be forwarded if it contains multiple devices. In almost any end-user case, this will not happen, and a DMZ will point to one device. (Note that this device can be another NAT, in which case ports will obviously still need to be forwarded) –  user56 Jun 7 '11 at 21:36
    
@mxmissile Specifically, from the manual of the router in question: "The DMZ feature allows one network computer to be exposed to the Internet for use of a special-purpose service such as Internet gaming or videoconferencing. DMZ hosting forwards all the ports at the same time to one PC. The Port Range Forwarding feature is more secure because it only opens the ports you want to have opened, while DMZ hosting opens all the ports of one computer, exposing the computer to the Internet." –  user56 Jun 7 '11 at 21:42
add comment

3 Answers 3

Have you tried turning off DMZ?

Basically DMZ is "all ports open for target machine" so if you open ports on a DMZ machine, unknown behavior may result.

You shouldn't mess with MTU unless you know exactly what you are doing. MTU has nothing to do with port forwarding. In networking terms, MTU is level 2 (ethernet/wireless layer) while port forwarding is level 3-4 (TCP/IP).

Also, the fact that it is a XBOX or a cell phone or a microwave oven doesn't (shouldn't) really matter. When you power cycle (turn off/on), only the router should matter and most router do this by default when you change routing tables (NAT port forwarding)

share|improve this answer
add comment

It looks like there may be a few other ports you can try opening up: UDP 53 TCP 53

I just grabbed these off Xbox Support that I noticed not on your list. There may be something else helpful on that page if you haven't seen it already, but looks like you may have.

You can also check your Port Forwarding settings for your router, Linksys WRT160N, here.

If you're really bored you can read this artical about the NATs and Xbox Live, though I don't think there's anything really helpful in there with troubleshooting your setup, it just explains how it all works and why Open NAT is helpful to have.

share|improve this answer
    
Well I tried adding port 53 for TCP and UDP no luck. Turned off the cable modem, router and xbox and tried again, still moderate. Read the guide, also interesting but didn't fix the issue. –  Tom Seibert Dec 4 '10 at 20:10
    
Hrmm. Are you running wireless or wired? Any possibility of wiring it direct to your cable/dsl modem or whatever you'r connection is using just to check you can get Open NAT w/o the router in between? If so, you'd have to remove the static IP from the xbox first. –  Doozer Blake Dec 4 '10 at 21:51
    
It is wireless, but I have to do that because of the distance. I will see if moving stuff where I can wire it makes a difference. –  Tom Seibert Dec 5 '10 at 22:08
add comment

I have a linksys WRT120N (or 160 I can't remember at the moment) and the only way I've been able to get my xbox to recognize my NAT type as Open was to use a static IP address on the xbox over a wired connection and setup DMZ for that IP address in the router settings.

share|improve this answer
    
I've heard that as well. It seems a wired connection is required for open NAT –  Tom Seibert Mar 9 '11 at 21:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.