Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I was wondering, I have optifine and I can get HD yexture packs but if I get anything over 128x Minecraft crashes. Why is this happening? My computer is very new and has great proccesors and graphics cards. My processor is an intel i7 3,4Ghz and my graphics card is a one of the higher AMD Rathelons and I usually get 200fps with Minecraft. I also have 8GB of RAM.

EDIT: When I use mc-patcher with a 256x256 texture pack I get this error report:

---- Minecraft Crash Report ----
// Would you like a cupcake?

Time: 6/23/13 7:46 AM
Description: Rendering screen

java.lang.OutOfMemoryError: Java heap space
    at bio.a(SourceFile:388)
    at bio.<init>(SourceFile:136)
    at bio.<init>(SourceFile:108)
    at biq.a(SourceFile:127)
    at biq.c(SourceFile:94)
    at bir.b(SourceFile:80)
    at bge.d(SourceFile:350)
    at bge.c(SourceFile:301)
    at bjx.a(SourceFile:146)
    at axt.a(SourceFile:175)
    at bjw.a(SourceFile:109)
    at bfq.b(SourceFile:768)
    at net.minecraft.client.Minecraft.K(SourceFile:597)
    at net.minecraft.client.Minecraft.run(SourceFile:526)
    at java.lang.Thread.run(Unknown Source)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
    at bio.a(SourceFile:388)
    at bio.<init>(SourceFile:136)
    at bio.<init>(SourceFile:108)
    at biq.a(SourceFile:127)
    at biq.c(SourceFile:94)
    at bir.b(SourceFile:80)
    at bge.d(SourceFile:350)
    at bge.c(SourceFile:301)
    at bjx.a(SourceFile:146)
    at axt.a(SourceFile:175)
    at bjw.a(SourceFile:109)

-- Screen render details --
Details:
    Screen name: bjw
    Mouse location: Scaled: (125, 143). Absolute: (375, 530)
    Screen size: Scaled: (427, 321). Absolute: (1280, 961). Scale factor of 3
Stacktrace:
    at bfq.b(SourceFile:768)
    at net.minecraft.client.Minecraft.K(SourceFile:597)
    at net.minecraft.client.Minecraft.run(SourceFile:526)
    at java.lang.Thread.run(Unknown Source)

    -- System Details --
    Details:
        Minecraft Version: 1.5.2
        Operating System: Windows 8 (amd64) version 6.2
        Java Version: 1.7.0_25, Oracle Corporation
        Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
        Memory: 5540872 bytes (5 MB) / 904527872 bytes (862 MB) up to 954466304 bytes (910 MB)
        JVM Flags: 2 total; -Xms512m -Xmx1024m
        AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
        Suspicious classes: [com.prupe.mcpatcher.MCPatcherUtils, Config, MCLogger, ...], [com.prupe.mcpatcher.mod.ColorizeItem, AAHelper, TessellatorUtils, ...]
        IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
        LWJGL: 2.4.2
        OpenGL: AMD Radeon HD 7570 GL version 4.2.12002 Compatibility Profile Context 9.12.0.0, ATI Technologies Inc.
        Is Modded: Very likely; Jar signature invalidated
        Type: Client (map_client.txt)
        Texture Pack: 1.5TP_HD_By_Lancer_256x256.zip
        Profiler Position: N/A (disabled)
        Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
share|improve this question
    
Specs please... –  Jeffrey Lin Jun 23 '13 at 11:20
    
Do you have any mods installed? They can sometimes mess up HD texturepacks. –  RustyMembers Jun 23 '13 at 12:00

2 Answers 2

The problem is that Java is running out of memory:

java.lang.OutOfMemoryError

Even if you've got 8GB in the system, Java can't use it all unless you let it. Right now, Java is only being given the default amount that Minecraft asks for, which is not quite 1GB:

Memory: 5540872 bytes (5 MB) / 904527872 bytes (862 MB) up to 954466304 bytes (910 MB)
JVM Flags: 2 total; -Xms512m -Xmx1024m

That's too little to run a 256x256 texture pack. To give Java more memory, you have to run Minecraft with a command line (in a batch file or script) that changes those memory flags, or use one of the alternate launcher that lets you specify the amount of memory to allocate.

share|improve this answer
    
How exactly do I do that? –  EthanBaconGaming Jun 25 '13 at 13:58
    
Wait the link you put is out of date. My java folder is jre7 –  EthanBaconGaming Jun 25 '13 at 14:04
    
What should I do now? –  EthanBaconGaming Jun 25 '13 at 14:04
    
@Ethan Use that command but edit the folder so it's right, I should think. (You probably don't need the folder path anyway—my own batch file just starts with "javaw" without the whole JRE folder path and it runs fine.) Or go find a new Minecraft launcher, and look for one that let's you set the memory with the GUI. Or use a 128x128 texture pack, since on your specs you will probably not like the performance of 256x256 anyway. –  SevenSidedDie Jun 25 '13 at 15:21
    
Minecraft still crashes even with it linked to my 64 bit version of Java. –  EthanBaconGaming Jun 25 '13 at 17:00

Try using MC-Patcher. Optifine doesn't work to good with some HD texture packs.

share|improve this answer
    
How do I install mcpatecher and use an hd texture pack with it? –  EthanBaconGaming Jun 23 '13 at 12:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.