Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I can't get my soldier dwarves to wear proper armor and use actual weapons. Here is what I have done:

  • I have assigned dwarves to be part of a squad, and defaulted their armor to 'metal'.
  • I click e for equip
  • For each soldier in the squad, I delete 'indiv choice melee', change to w for weapon, and then I pick 'battle axe'
  • My weaponsmith has forged iron breastplates and iron battle axes.

I do all this and nothing happens. Looking at the soldier's inventory, I see that they're still wearing their old clothing (ie, spider silk dress). None of them seem to be wielding the axes either.

I thought maybe they didn't' understand, so I went to the military screen, picked a soldier and assigned 'metal breastplate' and 'breastplate'. This did not change a single thing.

I'm not sure if this matterss, but I noticed on the top of the equip screen there is the text:

r: Over Clthng

How do I get my soldiers to be properly equipped?

share|improve this question

2 Answers 2

Your soldiers will only equip themselves while they are on active duty. In order to put them on active duty, you will need to press s to open the squad interface, a to select your squad, and t to put them on the active/training schedule. Then you will need to set up a barracks for them by building an armour stand or weapon rack in a room, and designating that room as a barracks. Once designated, access the room settings with q and press t to set that as your squad's training room. Your dwarves at that point should equip themselves, head to that room, and begin training. For more information, look at the various military related articles on the wiki.

share|improve this answer

Pressing r to change "Over Clothing" to "Replace clothing" will make your dwarves remove their clothes and put on their armour instead. Sometimes, they seem to not be able to wear armour when they already have clothing on.

At least that solved the problem for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.