Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

For comparison, I noticed in Blizzard's other game, World of Warcraft, you can explicitly specify in a configuration file (C:/Program Files/World of Warcraft/WTF/config.wtf) to use OpenGL (SET gxApi "OpenGL"). Does this ability exist in Starcraft 2? I found the configuration file (.../My Documents/Starcraft II/variables.txt) but I don't see a line I can modify to tell it to use OpenGL.

I know that running the game on Mac requires you to use OpenGl and not DirectX, however, can I use the OpenGL library instead of DirectX9 on Windows?

I don't know if the technical details of my problem will help, but here is what I hope to accomplish by using OpenGL. Currently I am running Windows programs on Ubuntu 13.04 using Wine 1.6-rc4. Prior to release of HoTS, Starcraft 2 actually ran (though choppy) making DirectX9 calls to Wine. However, since HoTS I'm stuck running at 0 fps when I try to play a mission (it's more like 1 frame per minute). I was able to get World of Warcraft to run smoothly by telling it to use OpenGL.

My machine is rather old, using ATI Radeon Xpress 1100 integrated video card. AMD doesn't provide new linux drivers for legacy cards, the drivers that are currently on their site are compatible with outdated versions of x.org. So for the record, I am using OpenGL drivers. However, most new cards come with drivers that are compatible with OpenGL and DirectX9/10, so it wouldn't be too far a stretch to think Blizzard would give you the option to use OpenGL as it did with World of Warcraft.


Oh I forgot to mention, I followed the following directions from AppDB, I don't know if it did anything though:

Regedit video performance tweaks

Some users report that the following registry edits can increase video performance. Some users report that these changes make no difference, and some even report that they make things worse! Feel free to experiment....

  1. Access the registry: wine regedit
  2. Navigate to HKEY_CURRENT_USER/Software/Wine/Direct3D. If this key does not exist, create it.
  3. Right click on Direct3D, and select New > String Value to add each of the entries below.

Key Value
DirectDrawRenderer opengl
Multisampling disabled
OffScreenRenderingMode pbuffer
UseGLSL disabled
VertexShaderMode hardware
VideoMemorySize (Set this value to the RAM on your video card, in MB)

share|improve this question
1  
Did you try to launch it with -opengl as paremeter? Would be the first thing I'd try. Works with WoW too. But your card is seriously outdated. –  NoneOfYourBusiness Jul 2 '13 at 21:04
    
@NoneOfYourBusiness how would I do that? From terminal, like wine starcraft\ II.exe -opengl? Sry, not that familiar with running wine with arguments, somewhat of a noob here. Also, how do I tell if it worked once I'm running the game? –  Nil Jul 2 '13 at 21:07
1  
That is not easy to tell, not even under Windows. You cannot see it in the binaries dependencies, since it has deps to DirectX and OpenGL. You can try to use gDebugger though and see if it makes any function calls to OpenGL, but if you are not familiar, it is not an easy task. But your assumption about how to run it is correct. You can also do this via a shortcut on the desktop. –  NoneOfYourBusiness Jul 2 '13 at 21:27
    
@NoneOfYourBusiness there was no difference in performance, however there was this output in terminal (from what I could scroll back to) fixme:d3d:resource_check_usage Unhandled usage flags 0x8. It repeated for a while. It seems as though Starcraft 2 is still making calls to direct x. I'm inclined to believe that Starcraft 2 isn't built to use OpenGL, though I can't find anywhere on Blizzards website or forums that says that. –  Nil Jul 2 '13 at 23:01
1  
I digged into it, even though I do now own the game and found that there is no OpenGL support in SC2. Bummer, normally Blizzard games have that. Looks like my google fu is stronger than yours :P –  NoneOfYourBusiness Jul 2 '13 at 23:41
add comment

1 Answer

up vote 4 down vote accepted

According to this post on Blizzards Forums by a support member, it is not possible to run Starcraft II in an OpenGL Mode at the moment. It has only DirectX Support.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.