Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a Logitech wireless gamepad which is not recognized by AC. Any ideas?

share|improve this question
    
Is your gamepad recognized by any other games/tools or is this problem exclusive to Assassin's Creed? –  Mana Dec 7 '10 at 5:23
add comment

5 Answers

Most new PC games only have built in support for the XBox 360 controller. You can use your Logitech controller by having it emulate an XBox controller.

Please refer this post. Basically you have to copy two files in to the game directory (the one where the .exe file is) and when you start the game, you should have all the controller options enabled. I've tested this method on several games with a Logitech Rumble Pad 2 (wired) and it works perfectly.

Download link (might be broken but you should be able to find it by searching for "XBox360 Emulation v3.0")

share|improve this answer
add comment

For people who have the F310/510/710 gamepads Assassins Creed and most new games will work by default if you switch the button at the back of the gamepads to "X-input". The gamepads will support vibration also.

For people who have Rumblepad 1/2 and Dual Action gamepads most games will not work by default because these gamepads only have "D-input". In that case you will need to set up "profiles" for each game using the Logitech Profiler software. It does take time to set up profiles though, especially if you are new. I make profiles for Logitech gamepads and upload them on the internet so people can just download them and play games instead of going through the hassle of setting up profiles themselves.

Go here to download the profiles I have made so far.

For latest games I have profiles for NFS Most Wanted 2012, Assassins Creed 3 and Borderlands 2.

share|improve this answer
1  
Hi @Mohammad, and Welcome to Arqade! This is a good answer, but in the future, please don't obfiscate links by using a link shortener service. –  MBraedley Jan 16 '13 at 15:16
    
@MBraedley Sure. I actually started doing that so that years later when I change the host of my files I can still keep the download links working without having to go back to every answer I gave and edit them. –  Optimus Prime Mar 23 '13 at 10:58
add comment

Make sure that:

  • You have the latest drivers for your gamepad
  • When control sticks are in neutral position, you've configured the gamepad in Control Panel > Gaming Devices

If you can't get it working just for Assassin's Creed, then you should look into using a tool like Joy2Key to map your keyboard controls to your gamepad to get around the fact that it's not recognized by Assassin's Creed.

share|improve this answer
add comment

Which gaming controller do you have? I have the F150 and I just use the profiler that it came with. If that doesn't work, I would recommend using Xpadder.

share|improve this answer
add comment

Make sure the gamepad is turned on before you start AC and that no other controllers are connected.

In any case Xpadder should work no matter what.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.