Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am running a dedicated vanilla 1.6.1 server so that my friend over in America can connect and play along with me. The server is whitelisted, we're both in the list and have OP permissions. Playing creative mode.

We're building TNT cannons, some of which are designed to launch your player. We built one example which can launch a player over 700 blocks high - and my friend has no problem using this.

However, when I step in and launch myself, as the server host, it tells me that I am moving too quickly. My position is reset and I don't get launched in to the air. I have tried setting the allow-flight flag in the server properties file to true, but it still causes the warning to show.

Any ideas as to why I am affected, but my friend isn't?

Computer specs:

  • Intel i5 3570k processor @ 4Ghz
  • 8GB DDR3 @ 1500 Mhz
  • Sandisk Pulse SSD
  • NVIDIA GTX 670

Minecraft runs in windowed mode, but maximised.

My ping to the server is < 1ms (obviously), friend's ping is about 140ms.. Give or take 10ms.

share|improve this question
8  
I'm confused by the existence of close votes on this clearly-expressed problem. –  SevenSidedDie Jul 5 '13 at 14:57
    
Hm, you may just have to switch to Bukkit. You don't have to install any plugins, but Bukkit comes with options to disable this. –  avestar101 Jul 6 '13 at 3:18
    
@avestar101 Thanks for you reply. I made a copy of the world and installed Bukkit, but to no avail. Would you mind expanding on how Bukkit can prevent this behaviour? Edit: Forgot to mention that I have gone through the bukkit config files but couldn't find any useful settings. –  Alexbrock Jul 6 '13 at 13:29
    
@Alexbrock 1. Open up bukkit.yml, in the same folder as your server jar. 2. Look under the first section settings. 3. Find kick-on-speedhack and set it to false. (All of this was taken from a post on Minecraftforums.net) –  avestar101 Jul 6 '13 at 15:54
    
@avestar101 It appears that the settings may have been deprecated some time ago. I'm currently experimenting with different plugins to see if I can work around this, but I'm still open to other potential solutions. –  Alexbrock Jul 6 '13 at 19:38
add comment

1 Answer

My bukkit server still has the kick-on-speedhack parameter in the bukkit.yml file, but that might not be evidence of it being deprecated.

Add: kick-on-speedhack: false

under settings: anyway to give it a go if you haven't already.

share|improve this answer
    
They're running vanilla, so Bukkit solutions probably won't help much. –  dlras2 Jul 9 '13 at 19:44
    
Thanks for your suggestion. I'm afraid that even with the addition of bukkit, this feature appears to not work. –  Alexbrock Jul 10 '13 at 23:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.