Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I decided to play good old Dungeon Keeper game again (the first one).

But I have horrible lag in the game, I think it depends on the map I play. The game also crashes after long games.

I've never had this problem before when I played it on XP. Maybe it's an ATI card problem, hard to say.

So, has anyone has problems like this? I would like to get rid of the mouse lag, it looks like the game message system (which handles mouse and keyboard) bandwidth gets full or something like that.

So, maybe I can somehow limit my CPU/GPU speed with some program? Is there any?

PS I cant play this game on DOS, so DOSBox won't fix it.

share|improve this question
What compatibility mode are you running in? – Stuart Pegg Dec 13 '10 at 12:40
@Stuart Pegg, I've tried every possible mode. – oldschool Dec 31 '10 at 19:57

Given that compatibility mode isn't work out, and you've some other issue with DOSbox, I'd recommend setting up a VirtualBox.

If you got an old Windows 98 (preferably) or 95 CD it's surprisingly easy to set one up.

One of the bonuses is the hardware virtualisation; you can set it to match the game's recommended spec (minimum 75MHz and 16MB RAM, ouch) to avoid some issues.

I've already done this to run X-Com Apocalypse, and it's as stable as it was first time round (at least it reboots faster now).

share|improve this answer

Just run in lowest resolution (640x)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.