Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just hooked up my computer to a Sony Google TV via a DVI-to-HDMI cable and at the same time my monitor is still hooked up, so I'm on dual-display now. The video, the graphics, and the resolution all look great and crystal clear on the HDTV. The problem I have though is that its responsiveness is slow.

I don't know how that's possible, but any mouse or keyboard interaction I do, I can feel at least a half-a-second delay until the HDTV displays my input. For example, if I click on an icon, I can visually see it selected after at least half a second.

So I wanted to see how much that would affect gaming, I fire up WoW and it is so difficult to play with that lag. Moving around, casting spells, and clicking buttons are all on that same 500ms delay.

Make no mistake though, I don't see a lag in graphics -- I get the normal 60-75 fps just fine, but it feels like it takes a while for the display to display. And the weirdest thing is that if I move over the mouse to the normal monitor, the responsiveness is absolutely normal. Move it back to the TV, and it's on that lag again.

So the question is, who is the culprit?

  • The DVI-to-HDMI converter cable?
  • The graphics card?
  • The Sony Google TV itself? Any special settings I don't know about?
  • Is it just HDTV being HDTV and this whole thing is expected? (I don't like this answer).
share|improve this question

4 Answers 4

up vote 6 down vote accepted

Nearly every TV nowadays (really any "HDTV") has lag, because it does a lot of post-processing on the video signal. Chiefly, any "motion smoothing" (120/240Hz) technology will create this lag. The most frequent way of resolving this is one of two things:

  • Find some kind of a mode like "Game Mode" and turn it ON.
  • Optionally, find any video enhancing modes (like the aforementioned motion smoothing) and turn them all OFF.

You want as close to a pass-through signal as you can possibly get. This isn't usually a problem on VGA/DVI interfaces, but since it's going into the TV HDMI, you've crossed into the world of enhancing typical consumer devices like DVD/BD players, game consoles, or even plain 'ole TV via a cable/satellite box.

share|improve this answer
    
Off-SE Related, but unfortunately devoid of any specific instructions for what to turn off/where to find any sort of game mode: gamespot.com/pages/forums/show_msgs.php?topic_id=27511987 –  VxJasonxV Dec 10 '10 at 23:16
1  
I'm very obsessed with this now... further reading for anyone about this common phenomenon that I was completely oblivious to: en.wikipedia.org/wiki/Input_lag –  BeemerGuy Dec 11 '10 at 1:42
    
This subject matter is all over gaming. Between twitch action like Pro-gaming Starcraft Leagues, to FPSes, and Music Games especially. It's a big deal once you start having to care about it. –  VxJasonxV Dec 11 '10 at 1:58

Thanks to VxJasonxV, turns out the TV itself is the culprit, as admitted by Sony itself.

Here's a quote from Sony eSupport website:

There is a lag or delay on the TV screen when playing video games.

Solution: Some users may experience a slight lag or delay in response time when connecting the Internet TV device to a game console. This is a natural result of the advanced processing circuitry in the Internet TV device. This is normal operation.

Region: United States
Products: NSXGT Series

And here's a link to that:
http://www.kb.sony.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&externalId=C1020032&sliceId=1&docTypeID=DT_KNOWLEDGEARTICLES_1_1&dialogID=203768311&stateId=1%200%20203774222

That "solution" is basically telling me "return your TV to us for a full refund".

share|improve this answer
    
My Bravia has a Game Mode. They're seriously saying that you can't do anything about it with this "Google TV"? Wow. –  VxJasonxV Dec 11 '10 at 1:10
1  
+1 for irony... –  Zommuter Sep 17 '11 at 11:14

I fixed it on my Sony AQUOS by going to Settings > Video > Advanced and disabling "Motion Enhancement." Much faster now!

share|improve this answer

Sony internet TV's are extremely annoying to play video games on or to use as a monitor because of this problem. Although there is no "game mode" that many Samsung and Panasonic TV's have, you can still disable some post processing features to mitigate the problem. Here are some things you can do to decrease the amount of video processing the SONY internet TV and thus decrease the output response time:

  1. On your Sony internet TV keyboard remote press and hold the Fn (function) key on the bottom left of the remote and while holding press the 1! key to enter the menu
  2. Scroll or move cursor down to select the "TV settings" option and make sure Picture adjustments lock is set to "Unlock"
  3. Go back to the previous menu (main settings menu) and select "Picture & sound"
  4. Select "Picture adjustments" and set "Picture mode" to "Standard"
  5. Enter into "Detailed settings" menu and set "Color temperature" to "Neutral"
  6. Set the following settings to "Off" : "Noise reduction", "MPEG noise reduction", "CineMotion", "Black corrector", "Adv. contrast enhancer", and "Live color"
  7. Make sure other options that use picture processing are turned off or to 0 like all the options inside the "White balance" setting
  8. It is questionable if any of the sound settings affect the video processing time, but to be on the safe side, set sound mode to standard if you're running sound through your HDMI. The TV automatically syncs audio and video, so do this to be safe.

After these settings, I noticed a huge difference from maybe 500ms down to 200ms. and made it bearable to use the internet tv as a monitor.

Hope this helps guys. Happy gaming.

share|improve this answer
    
200ms? That's still huge, and definitely perceptible. –  MBraedley Feb 19 '13 at 22:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.