Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm playing Dark Souls: Prepare to Die Edition and I'm having a bit of an annoyance. I always play my games, if possible, in a custom resolution (in my case 1900 x 1000), so that the game's window almost takes my whole screen, but there is room for its title bar and Windows' taskbar.

I tried to do that in Dark Souls (both in the configuration file in my Documents folder and in DSFix's options), but it had no effect. The window always took my full screen, 1920 x 1080.

Then I tried the option for a borderless full screen window, and that worked rather well (minus the frustration from not seeing my taskbar) until I found that at some point, after a few alt-tabs, the window will soon become unusable, because it'll set itself to be behind everything else, and as a result all you can see of the game is a very small strip through the transparent taskbar.

Now I'm playing in proper full screen, which is free of the borderless window's bug, but then there's the annoyance of having an annoying delay on each alt-tab, not to mention the game's sound is cut when I'm on another window, so if I'm attacked while I was busy elsewhere, I'll never know and will find myself by a bonfire when I come back. Although this last point, I'm not sure it's exclusive to full screen.

So uhm, how can I set my custom resolution and play comfortably, the way I'm used to?

share|improve this question
add comment

1 Answer

It is possible to set your custom windowed resolution using DSFix by setting the resolution using

renderWidth 1900
renderHeight 1000

and using forceWindowed 1. Without force windowed, the game will use one of the preset resolutions.

That being said, I also found out that the intro scene was a bunch of white vertical lines and I could not enter the main menu or even start playing. I hope this won't be the case for everyone, but I fear it might.

share|improve this answer
    
Same effect for me, sadly. After all, it does say the options are not ready to be used. Is there no other way? ._. –  Ariane Aug 2 '13 at 17:40
    
@Ariane I couldn't find another way and I doubt there is one. –  3ventic Aug 2 '13 at 18:42
    
Sigh. Annoying. In Dark Souls' configuration file in the Documents folder, if I change the resolution by hand and then launch the game, the file gets overwritten again and my custom values gets replaced by 1920 and 1080. Say, I'd like to try something. How, in Windows' security options, would I forbid Dark Souls from modifying its configuration file? If I'm lucky it just won't overwrite it instead of giving me the expected error message. –  Ariane Aug 2 '13 at 22:38
    
@Ariane you can flag the file read-only after editing, before launching the game. That might help. I cannot find any configuration in my Documents to test it out. –  3ventic Aug 3 '13 at 9:43
    
That's odd. I was sure there was such a file and I was sure I had modified it and seen it be overwritten by Dark Souls, but now I can't find it at all either. I guess I confused it with something else. –  Ariane Aug 3 '13 at 14:14
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.