Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have just installed the shaders mod to make a Minecraft Machinama, but the lag from all of the shader packs are terrible! My FPS drops from 300 to 30 with almost every single one! So I am wondering if there is any possible way to reduce the lag without having to lower my settings. Thanks!

share|improve this question
3  
If your computer is lagging due to shaders, that means it's not robust enough to handle the increased graphics load. To make it faster, decrease the load. There are some other techniques you can use to help, but most of them involve upgrading your hardware. –  Frank Aug 24 '13 at 21:03
    
@fbueckert How can I decrease the load? –  EthanBaconGaming Aug 24 '13 at 21:03
2  
The most obvious way would be to lower your settings. Others would be to close everything else you have open. If you've already closed everything, then I'm afraid there isn't much else available. Either lower your settings, or buy better hardware. –  Frank Aug 24 '13 at 21:05
4  
Are you using a laptop? A 10-fold decrease in FPS with shaders active suggest to me that you might be using integrated graphics instead of a discrete GPU. –  SevenSidedDie Aug 24 '13 at 21:12
1  
I'm assuming you are talking about the mod causing a low FPS, and not lag? Also, there is no need to capitalize every word in the question title. –  avestar101 Aug 24 '13 at 23:12

2 Answers 2

up vote 2 down vote accepted

Asking to impove fps without reducing settings is a bit strange, optimisations usually require compromise. If your PC/Laptop doesn't have the hardware for the task there isn't much you can do about it.

If for some reason you haven't already installed optifine, this would be a good first step, after that reduce settings to a level where everything looks as good as it can without ruining framerate.

bear in mind that if you are attempting to record play with something like cam-studio or fraps, your frame rate will reduce significantly again while the recorder is in use

Good luck :)

share|improve this answer

Another thing you can do, if you have a Windows computer, is to go to Task Manager and set the priority of "javaw.exe" to High or Realtime.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.