Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When I try launch Witcher 2, it gives me an error that says "Failed to start game (missing executable). I've tried verifying the game cache.

share|improve this question
1  
It might be your antivirus program not allowing it to run. Try turning off your antivirus (temporarily) or running the launcher as Administrator. –  Krazer Aug 25 '13 at 19:13
3  
Navigate to the folder that should contain the executable (C:\Programs\Steam\steamapps\common\Witcher 2) and check if it actually exists. –  yassarikhan786 Aug 28 '13 at 18:43

3 Answers 3

I recently moved my OS to a new SSD and as a result, the steam folder stayed behind on my old 2TB SATA drive. Many games worked, but quite a few gave me the same error. I searched high and low for a solution after moving folders about and installing Steam as described on a number of sites. Ultimately, the only fix was to uninstall the game through steam, then reinstall it.

The best part of this is that because Steam isn't actually sure where the game is, (thus the missing executable error, despite plainly being able to find it when I manually browse to the folder) is that the game data isn't actually deleted. I then reinstalled the games, and it would claim that it had downloaded the full game in just minutes - it actually appeared to discover the game files, check them and then work fine. I will say that this was the case for almost all of my games, with the exception of I believe one of the Batman: Arkham games, which actually did spend an hour downloading ~7GB or whatever it is.

Verifying the game cache did not work - as Steam appeared to be looking in the wrong place for the game.

share|improve this answer
  • Let your antivirus allow the game/turn it off
  • Reinstall the game

Maybe something went wrong when downloading the file? Check if there is a .exe and try running it? Maybe redownload if that doesn't work.

share|improve this answer

I would try reinstalling the game, so it has to re download all of the files. My Ace of Spades had the same problem, so I uninstalled it, and then re installed it, and it starting working again.

share|improve this answer
    
This seems like overkill. Verifying the game cache will automatically re-download anything missing or corrupt. –  Matthew Read Sep 11 '13 at 16:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.