Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a PC running Windows 7. I installed and play Age of Mythology and its expansion, the Titans. Since the computer I have is much, much more advanced than even the maximum supported graphics settings in AoM, and I often multitask, I want to run it in windowed mode.

As it is, the game runs in the center of the screen at the resolution I select, surrounded by a black border.

I have tried the following:

  • Checking the "Windowed mode" box in the game's settings
  • Hitting ALT-Enter while in the game
  • Creating a shortcut and adding "-w" and "-windowed"
  • Running it from the command line using "-w" and "-windowed"
  • Running it in every available compatibility mode

None of these had the slightest effect, except ALT-Enter, which causes a momentary flicker during which I can see the outline of the window and the minimize/maximize/kill buttons in the top right.

Is there anything else I can do, or is it simply not possible? If not, can anyone tell me specifically why, in case it is a problem I can create a workaround for?

share|improve this question
    
Sorry I'm not answering your question, but the game is hard to keep up with on its own, are you sure you want to multitask? –  user52549 Aug 26 '13 at 11:42
1  
@user52549 - I think what he means is he pauses the game to chat to friends, look at strategy guides etc. I don't think he leaves it running unpaused. –  Robotnik Aug 26 '13 at 12:51
    
Oh, so in this case alt+tab doesn't work? –  user52549 Aug 26 '13 at 15:21
    
@user52549 - depends how often he switches out. Once or twice per game, alt-tab is probably fine. I've found with alt tab though, it tends to reposition the camera in the far corner of the map, which gets annoying after a while. In any case I can see the benefits of wanting to run the game in windowed mode –  Robotnik Aug 27 '13 at 10:05
    
I am sure I want to multitask, yes. It's not particularly problematic the way I play the game. Anyway the issue is a technical one; I'm puzzled as to why I am unable to make it work when it seems to work in similar situations for other people. –  David John Welsh Sep 1 '13 at 13:45

1 Answer 1

At least on steam, Using ALT+ENTER does switch the game to windowed mode, but initially you will only be able to tell by the flicker you described. You must still change the screen size in settings to a smaller value to make use of windowed mode.

enter image description here enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.