Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have build two portals in Minecraft now, and neither of them seem to work. This is on a multi player server.

They were built correctly, and they both have the purple portal tiles in the center. But, when I stand in the center of the portal, nothing happens.

What am I doing wrong?

share|improve this question
    
Are you in single player mode? Portals don't yet work on multiplayer servers. –  Raven Dreamer Dec 20 '10 at 7:55
2  
@Raven, oh. Shoot. That would do it then. Could you make this an answer and link to a reference? –  jjnguy Dec 20 '10 at 7:59
add comment

3 Answers

up vote 20 down vote accepted

Are you in single player mode? Portals don't yet work on multiplayer servers.

Specifically, there is a multiplayer server command, "hellworld=true" that is applicable for testing, but is buggy and not yet fully implemented.

As of 1.6, Nether Portals do work in SMP. Make sure you're updated to 1.6 or later if you're trying to access the nether in SMP.

share|improve this answer
add comment

Portals don't currently work in multiplayer because of the way the code was written. In the single-player game, when you enter a portal, the normal world gets unloaded and the Nether world is loaded instead. The same process happens in reverse when you return from the Nether.

On a multiplayer server, the normal world can't just be unloaded willy-nilly, since other players may still be playing on it! This means that for portals to work correctly the server would need to have the normal world AND the Nether loaded at all times and that's currently not possible.

Presumably this is because the server code was originally written with the assumption that there is only one world loaded (or possibly there are just memory issues with having both loaded at once), so until Notch refactors the server code to allow for both to be loaded at once, we're stuck with no portals in SMP.

share|improve this answer
    
Thanks for the more detailed description. –  jjnguy Feb 15 '11 at 15:46
add comment

In 1.7, check your server.properties file and make sure the nether option is set to "true".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.