Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Alright, so for the last 2 days I've been trying to figure out how to solve this issue with Skyrim, Fallout 3, and New Vegas.

When starting Skyrim, my mouse responds fine, but my windows cursor occationally also appears. To solve that, I'd alt-tab and play the game as usual. However, 2 days ago, I updated my Nvidea driver. Ever since, when I'd alt-tab and come back, my windows cursor would be gone, however, my mouse would lag, jitter, shift speeds randomly, and 'slide on'. These things, apart from the windows cursor appearing, also happen in both Fallouts. (I figured they all have the same problem, since their gameplay engine is exactly the same only modified for each game, thus I'll use skyrim to test)

I have already tried the following:

  • Toggling iPresentInterval.
  • Toggling bMouseAcceleration.
  • Adding fMouseHeadingYScale and fMouseHeadingYScale.
  • Removing and altering fMouseHeadingSensitivity.
  • Rebooting.
  • Turning off gamepad options. (seem to have been on by default)
  • Reducing graphics. (usually play smoothly at maximum everything)
  • Disabling Logitec acceleration.
  • Disabling Logitec driver reliance.
  • Disabling windows cursor acceleration.
  • Forcing V-Sync off with Nvidea Control Panel. (3D Settings)
  • Disabling 2nd screen.
  • Shutting down some background processes. (used to be unnecessary)
  • Changing mouse sensitivity.
  • Re-installing Skyrim.
  • Enabling and Disabling MSI-Afterburner.

Take note of the following:

  • Somehow these issues are inconsistent and don't appear in very rare cases.
  • The issues are most of the time, only occurring before Alt-Tabing.
  • I have tested the xxPrefs.ini edits on all 3 games, generally yielding nothing.
  • There (so far) never occur any issues with my mouse, in windowed mode.
  • Currently, I use an Nvidea GeForce MSI N580GTX Lightning, with Forceware 320.49
  • I can run ANY other game (i.e. Bioshock Infinite and Metro Last Light) on high+ graphics (smoothly) (so far)
  • Up until the driver update, none of the 3 games had any real issues
  • Apparently I may have had such issues earlier with skyrim, and somehow managed to fix it, evident from backup files of a mod, that would help with this issue (if only I could remember)
  • Skyrim currently is patched to 1.9.32.0.8
  • [Edit] I am fairly certain, all 3 games have the same issue, so please avoid suggesting mods or workarounds, especially if focused on only one of the 3.

Please, any answers that could help in this would be great, though bethesda games are buggy, they also are some of the best ever made in my opinion.

If there are any further questions please ask.

Thank you for your help

EDIT: Though I appreciate the help in regards to the double cursor, this is not my primary issue! The double cursor issue is at most an annoyance, whereas the cursor movement bug makes it near unplayable, and is a separate issue from the double cursor issue. Additionally, the double cursor issue can be solved by a multitude of ways, and only rarely even occurs.

Please refrain from offering me help with my double cursor issue, as that is not what is breaking the game.

share|improve this question
3  
Why not use borderless windowed mode? –  kotekzot Sep 14 '13 at 22:01
3  
True, I am aware of this, however, seeing as it used to work, I rather have answers than workarounds. In other words, until my frustrations become more important than my pride. –  SpiritBH Sep 14 '13 at 22:07
2  
Tabbing out of Bethsoft games is almost always a recipe for disaster. Better to fix your double cursor issue properly instead of asking for a fix for the dubious no-longer-working workaround. –  SevenSidedDie Sep 15 '13 at 2:12
1  
What mouse? What Windows? Seems to be a Logitech to me, do you have the latest drivers for it? Also Full-screen is not really intended for Alt-tabbing. –  Steinin Nov 4 '13 at 15:14
1  
Vanilla releases from Bethesda aren't intended for human consumption. Skyrim is unplayable without SkyUI. New Vegas MUST have the Silent Hill fix. Fallout 3 doesn't matter as it can (should) be run from within New Vegas. –  Mazura Sep 5 at 0:50

2 Answers 2

up vote 1 down vote accepted

"Up until the driver update it worked", roll back your driver. Make note of any additional settings that disappear, and any different settings.


Skyrim: how to fix input lag and vertical sensitivity for mouse and 360 controller (PC) -YouTube

Most of these are ini tweaks. Try lowering your pre-rendered frames in the Nvidia control panel to 1. Cap the frame rate at 50fps.


Alternatively: (GameFAQs, --Helfire-1)

Enable adaptive Vsync (half refresh rate)

Enable triple frame buffering

Pre-render 3 frames

In the ini file: Mouse acceleration off {add bMouseAcceleration=0 to [Controls]}

In the standard options: Distant object detail (medium)


My settings: (Like in the video, it also took me 9+ hours to get Skyrim playable and like you I forgot half of what I'd done)

fMouseCursorSpeed=2.000 (fixes annoyingly slow menu cursor)

fMouseHeadingSensitivity=0.2000

fMouseHeadingXScale=0.2000

fMouseHeadingYScale=0.2000

The above allows you to make 180 degree turns in a single gesture, also:

bFXAAEnabled=0

RadialBlurLevel=0

bDoDepthofField=0

bDoHighDynamicRange=0

bUseBlurShader=0

bGamepadEnabled=0

Interestingly, I find no MouseAcceleration setting in my ini (I'm unsure how many problems SkyUI and SKSE have solved for me.)


If you have applied any ini tweaks, DO NOT adjust anything from the in-game menus.

share|improve this answer
1  
Finally a good answer. Turns out the fact that there are 2 SkyrimPrefs.ini files messed with the game. After turning off mouse acceleration about 90% of the issue was solved, and the remaining 10% wasn't noticeable after a little tweaking. –  SpiritBH Oct 20 at 0:22

There is a way to fix double cursor that i've discovered. Maybe someone else has too, I don't know. When you alt-tab out of the game:

  • try getting the game back by alt+tab or clicking it on the taskbar
  • if taking too long, ctrl+alt+del -> esc to force windows to redraw the screen
  • this is has to be done quick: you move the mouse around in the redrawing black screen until the cursor disappears. That means you found the position where you have left the mouse when you alt+tab'ed out of the game.

So basically when your mouse is in a different position when you alt+tab in then when you alt+tab out, you gonna have problems.

If you can't do this in one try, alt+tab out and try again.

Hope this helps.

share|improve this answer
    
I was already aware of these workarounds through trail and error. But my double cursor is not the primary issue as now noted with the question. –  SpiritBH Oct 18 at 16:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.