Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm running the Steam version of Dishonored, and I'd like to be able to bind a command to F6 disable HUD.

I've noticed that most people actually recommend changing the DishonoredInput.ini file, which I don't have in my Config folder, so I assumed that DefaultInput.ini would do it.

However it seems like any tweaks I make to my DefaultInput.ini file don't actually have any effect. I tried disabling the game's startup movies through there unsuccessfully (I eventually disabled them by renaming the movie files themselves, so I'm good there), and now I'm trying to include this line to disable HUD:

.m_PCBindings=(Name="F6",Command="ShowHUD_True")

But it's not working. Any ideas?

share|improve this question
1  
Backup the DefaultInput.ini file and then rename it to DishonoredInput.ini, see if that works. –  Petr Abdulin Oct 11 '13 at 6:39
    
Unfortunately, that gives me an error - "Failed to find default engine .ini file to retrieve My Documents subdirectory to use. Force quitting." –  rapturemachine Oct 15 '13 at 3:43
add comment

1 Answer

up vote 1 down vote accepted

Step 1: Disable automatic updates. Steam has so that it does not overwrite the changes you make to the ini files. You can do this by right clicking the game -> Properties -> Updates.

Step 2: Go to %USERPROFILE%\My Documents\My Games\Dishonored\DishonoredGame\Config\DishonoredInput.ini

Step 3: Add m_PCBindings=(Name="F6",Command="ShowHUD true")

Step 4: Press F6 Hide or display HUD.

Notice how the "config" folder in the SteamApps directory has only "Default" as start of ini names.

Notice how the "config" folder in documents has only "Dishonored" as start of ini names.

Directory Path

Correct Path: %USERPROFILE%\My Documents\My Games\Dishonored\DishonoredGame\Config\DishonoredInput.ini

Incorrect: C:\Program Files (x86)\Steam\SteamApps\common\Dishonored\DishonoredGame\Config

Code

Correct Code: m_PCBindings=(Name="F6",Command="ShowHUD true")

Incorrect Code: .m_PCBindings=(Name="F6",Command="ShowHUD true")

Enjoy and have fun!

share|improve this answer
    
Thank you so much, this worked! I didn't realize there were two different Config folders. Good to know! –  rapturemachine Oct 20 '13 at 1:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.