Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I bought Just Cause 2 via Steam and installed on Windows 7. My video card isn't great, but I could run the 3 test scenes at 30fps at 1280. When I played the game, it ended the first cut scene, I jumped out of the plane, it said loading, and it hung there forever. I restarted the game and the same thing happened.

I read that some other people have the same problem, too. Some suggested deleting the app files, which probably just resets the video setting. That didn't help. Suggestions?

Update: I checked the minimum requirements, and I believe my PC meets them all. I have an ATI Radeon HD 3650 card, and when I lower the resolution it does just fine (30fps) on the benchmarks.

share|improve this question
1  
Hi Jon, welcome to Gaming, it's an honor to have you here. I hope you find a solution for your problem! –  jmfsg Dec 28 '10 at 12:24
    
Not really of much use BUT, this is a great reason to check out OnLive's cloud gaming solution. I am by no means a hardcore gamer but I am very happy with it and they have Just Cause 2. –  Foovanadil Dec 28 '10 at 16:49

3 Answers 3

Well, let's see:

The minimum system requirements for Just Cause 2 are:

  • Windows Vista or better
  • Dual Core CPU with SSE3
  • 2 GB memory
  • 10 GB disk space
  • DX10 compatible graphics card with 256 MB of memory
  • DirectX compatible sound card

The specs for your ATI Radeon 3650 video card:

  • DirectX 10.1 support
  • I'll assume your card has 256 MB of video memory, but you should check

Did you update your video drivers to the latest version?

http://support.amd.com/us/gpudownload/Pages/index.aspx

That'd be the first thing I tried. Beyond that, your video card might be too "minimum" for the game to run -- the 3650 HD is very low end, it was a budget video card in January 2008, and I would not say it has aged like a fine wine in the last 3 years.. you might consider an upgrade to the 5xxx or 6xxx series.

share|improve this answer
1  
I've got the latest drivers. The weird thing is that it runs the benchmark scenes at 30fps no problem, and I've seen other forum posts from people with good video cards. I mostly just wanted to get this listed on gaming.stackexchange.com since looking through the random gaming forums for solutions made me want to suckerpunch a nun. –  Jon Galloway Dec 31 '10 at 0:06
up vote 3 down vote accepted

I found the answer on the Steam forums

I verified the files, which caused some to be re-downloaded. After that, the game played just fine.

share|improve this answer

Change your resolution and then try again! Worked for me

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.