Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Sometimes during marine drop when I detect that coming opponent forces are overwhelming I am trying to get all marines back into Medivacs and go back to my base.

Usually I have marines and Medivacs in one group and when I need to go back I do right-click this group on each Medivac with 'shift' key pressed.

Usually one Medivac is fully loaded while all others are empty and 5-10 marines are left... I am trying to get them back into empty Medivacs (keep right-clicking on them), but that doesn't help: marines stay on the ground, medivacs don't go to them to pick-up.

Question: Why? What am I doing wrong?

share|improve this question
add comment

2 Answers 2

up vote 12 down vote accepted

The problem here is that your marines and medivacs are in the same group.

When marines and medivacs are selected, and all medivacs are empty, right clicking a medivac will tell the marines to go in. When at least one medivac is full, the default action on right clicking will be to tell all units to move to that medivac (default action for the full medivac apply to the whole group).

Try having marines and medivacs in two separate groups (1 and 4 for example), double tap 4 to focus your medivacs, press 1 to select marines, shift right click right click right click, and when they're all loaded press 4 and fall back :)

EDIT: You can also select your group, right click a medivac, hit tab to select the medivacs, then press the shortcut 'load' instead of relying on the right click default action, that should work too :)

share|improve this answer
    
+1 for "load": It's underused, and it's by far more effective than trying to do it manually. –  Satanicpuppy Dec 29 '10 at 15:54
    
You might be able to just hit "tab" to select the marines instead of the medivacs instead of putting them in different groups. –  Resorath Feb 14 '11 at 21:20
1  
FYI, I tried using the latter strategy, using the "Load" option for the medivacs, and was not able to get it to work, so I would recommend sticking to the first part of this answer. The reason for this is that you have to manually select a target if you use the Load shortcut. –  kazzamalla Feb 14 '11 at 21:52
add comment

If you prefer not breaking up into multiple control groups, SHIFT+CTRL+Leftclick on a medivac icon in your group display before trying to load. That's an easy way to get the medivacs deselected, so you can use your current 'right click on the medivacs' method to load the rest of your unit mix

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.