Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm currently trying to avoid Windows XP mode since the Windows 7 installation itself is a VM (running on a Mac Mini). Regardless, here's my description of the problem.

The game successfully launches, but displays a black screen. You can hear the music play on the title world. I end up using ALT-TAB to switch out of full screen mode so I can quit. I know that once I get the game into windowed mode it'll work fine, however I've tried numerous command line switches to no avail.

I have the following compatibility options currently set:

  • Compatibility mode: Windows XP SP2 (also have tried Windows 98/ME and Windows 95)
  • Disable visual themes (at least required for the save dialog to appear)
  • Disable desktop composition
  • Run this program as Administrator (otherwise I know the game cannot save)

I have also tried (no success):

  • Run in 256 colors. I've also switched to the Windows 7 Basic theme and 800x600 resolution.
  • Run in 640x480 resolution.
  • Disable display scaling on high DPI settings.

I've tried the original game, with and without Corkscrew Follies installed, and with and without all known available patches.

So I'm looking to get the display working, regardless of method. If there's a command-line switch I can use to force a windowed mode (I've tried -w, -win, -window, -windowed) that would be just as fine.

share|improve this question
    
Might I suggest paying the extra buck and get a small used laptop for $200-$500 with Windows installation, which is what the game is designed for? =) I personally think it is less of a hassle than working my way around not only a 64-bit OS, but a VM within an OS that is incompatible with the client OS. Way too many variables in my opinion. –  BeemerGuy Dec 30 '10 at 22:51
    
...just out of curiosity, have you tried pressing ALT-ENTER after the screen goes black? I don't know if Rollercoaster Tycoon supports that shortcut, but most games do (assuming, of course, that they support both windowed mode and full screen). –  Michael Madsen Dec 31 '10 at 2:41
    
I've gotten it working before under Windows 7 64-bit in a VM (and have 17 other equally old games working fine). The problem is I don't remember how to get this one working, and Googling hasn't provided answers. There's just forum posts of "Oh, but it works for me". A second physical computer is not an option when VMs work fine. ALT+ENTER does nothing. The game's windowed mode is normally triggered under the options menu. The issue is either getting it to work while still in full-screen mode, or figuring out how to set windowed mode without having to do it through the game itself. –  The Lazy DBA Dec 31 '10 at 21:52
    
I'll agree with BeemerGuy on this one. There are just too many screws to play with, and we don't even know if it can be done reliably. I'd suggest closing this, as it is too localized. –  Bora Mar 5 '11 at 11:18
add comment

6 Answers

up vote 5 down vote accepted

The solution was to disable 3D acceleration in VMWare by unchecking the "Accelerate 3D Graphics" under Settings... options for the virtual machine.

This solved the issue not only for the 2010 Mac Mini, but also for a 2011 27" iMac.

This solved the issue not only for Roller Coaster Tycoon (original), but also with Corkscrew Follies, and the Deluxe edition.

share|improve this answer
    
Thank you! I searched for literally two days to figure this out; RCT wouldn't work for me on my 2011 Macbook Air under Crossover Office, under PlayOnMac, or in my Win7 VM -- at which point I realized there had to be something going on, but I couldn't figure out what. Turning off 3D acceleration did the trick! –  Christopher Schmidt Jul 12 '12 at 14:25
add comment

Alt tab out of the game, then go back in (click the game icon) - it worked for me.

share|improve this answer
    
Tried this before, and tried again. Screen remains black. Granted, the UI widgets are there. You can in theory, by luck, click around and get the game to quit, but everything is still black. –  The Lazy DBA Jan 27 '11 at 14:52
add comment

I've been able to run the game under Wine, so you may have better luck with that then in your Windows VM.

Instructions for installing Wine on your Mac are here.

share|improve this answer
add comment

Wine is what you need to install Window applications on a Mac which I used this YouTube video to install RCT on Wine. Make sure you read the description for the useful links which contains the important patch when installing RCT.

share|improve this answer
add comment

Run in compatibility mode for Windows 98/ME worked for me. Just saying so that people don't automatically think it never works.

share|improve this answer
add comment

It's been a while since I had RCT installed, but if I remember correctly there was a text file that had the game settings in it that you could modify (allowing you to set to windowed mode that way). If you don't want to go the route of installing Wine dig around a little bit in the game files and see if you might be able to find it there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.