Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

By default, the game is in Russian on my game console; however, I was able to do some hacking in menu and now the characters speak English, but the menu and text is still in Russian.

How do I fix this?

share|improve this question

Well, since I haven't faced the same problem I can only give suggestions.

Let me know if this works:

Start menu -> Run Type regedit Go to the folder HKEY_LOCAL_MACHINE\software\ubisoft\Assassin's creed II There's a value named Language, double click it and type English.

share|improve this answer
I forgot to add that its under xbox360(because I thought its the same for ps3 and I forgot about PC). thx fo answer anyway. – IAdapter Jan 11 '11 at 8:29
up vote 1 down vote accepted

I was able to fix it by creating new account and than switching languages and restarting the game(it doesn't change right away). The sad thing is that it has inherited the language from old AC2 game(there I didn't even try to fight it, because i already knew the game)

share|improve this answer

I had the same problem. Although I had the language set to english everywhere, it seems the game uses the system locale for the language in the menus.

The solution was to go to My XBox -> System Settings -> Console Settings -> Language and Locale and choose an english-speaking country for your locale. (Only changing the language did nothing in my case).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.