Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm been playing through Crysis with out a problem, but now that I'm at the last level (Reckoning) I've been having a lot of technical problems. I'm at the point where you have to battle the large spider robot on this ship deck. I'm can run around fine for a few minutes but eventually everything starts getting really choppy, and the sound starts to glitch. Eventually the program will crash into windows, although I did have it blue screen once.

Before this I had zero technical problems. I've search around the net and found that this is a common issue with this level, and the solution is to run the game in DX9 rather then DX10. This, however, does not seem to fix the problem for me. I've reinstalled the game, and reinstalled my video card drivers

Any one have any idea what else I could try?

CPU: Athlon II X2 250 OS: Windows 7 Home Premium 32 Bit RAM: 4 GB Video: ATI Radeon HD 5700 (Driveer 8.801.0.0)

share|improve this question

2 Answers 2

The same thing happened to me. Went smoothly more or less until that point, but the frames per second went down to like 0.5 on that last level. Completely unplayable.

My solution was just to lower all the graphics settings to minimum / close to minimum levels. Yes, it sucks, especially in such a beautiful, climactic battle - but I was hardly able to move otherwise. When it was low enough I was able to play through that battle relatively smoothly.

When I played the game my system was greatly inferior to your current system, so I suspect you could make do with just medium settings.

share|improve this answer
    
Ditto. I had the same problem, and I took the same approach as Oak. I was able to play through to the end at low settings. (Then when I upgraded my system a year later, I went back and played the ending at high quality to see what I'd missed. :-) –  Feral Chimp Jan 9 '11 at 4:54
    
That's quite interesting. Though I noticed a drop in the framerate, I was able to play the ending on High just fine (Core2Duo 1.8GHz, 2GiB RAM and GeForce 9600GT). And no, I do not consider that my system a good gaming system. –  Bobby Dec 4 '11 at 10:37

Try running the game on DX9 settings or switching among two directx setings. My PC is Win & 32-bit ultimate with AMD 965BE, ATI HD 5770 and uses Corsair XMS 2x2GB DDR 3 RAM. It might not be the case of a PC choking out (Crysis was reported as not properly utilizing PC resource which was supposedly identified and fixed in Warhead. So I guess more of the code or game engine tweaking).

share|improve this answer
    
Even if there was a marked answer, you're still welcome to offer another answer to the question. –  Wipqozn Mar 18 '12 at 20:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.