Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When i start Bioshock from steam, it hangs on the splash screen.

I have Windows 7 x64,and have installed all the latest drivers. HW details: i5 750, Asus P7P55D MB, ATI HD5770

share|improve this question
    
think the issue is still unresolved for me after all the updates on Steam. my bioshock is refusing to start up.. was able to play before –  jonleech Feb 14 '13 at 9:38
add comment

8 Answers 8

See here, have you tried this?

Right-click it on your Steam games list, go to Properties -> Local Files -> Verify Integrity of Game cache... wait for it to finish and download anything that might be missing and try running it again, don't forget to allow anything that might be needed to install before the first time the game launches.

I see you installed the latest drivers so I'm guessing that's not the issue (I found that most of the times my games won't run if I don't update my nVidia drivers and they get updated fairly often, you might want to check again for a newer version just to be sure).

share|improve this answer
1  
Ya, I did try verifying integrity of the game cache, It didn't help. –  NimsDotNet Jul 15 '10 at 4:37
    
@Nims, did you try running steam in compatibility mode? –  jmfsg Jul 15 '10 at 12:55
1  
Uninstalling the Rapture 3D Program did the trick. It was mentioned the last post in the thread you linked to. Thanks Juan! –  NimsDotNet Oct 29 '10 at 14:44
    
Glad you got it working @Nims –  jmfsg Oct 29 '10 at 15:27
add comment

The general answer, I suspect, has to do with the SecuROM copy protection. I find when I get a hang like this, it's usually because I have forgotten to kill a program SecuROM doesn't like. For example:

  • Any debugger, including Visual Studio.
  • Other runtime analyzers that might be used for binary hacking. E.g. anything in the Sysinternals collection (Process Monitor).
  • Stuff that interacts with the hardware at a low level, e.g. PerfectSpeed. (That one might be iffy. I haven't verified for sure that it blocks the game from running.)
  • Disk cloners like PowerISO and Alcohol 120%.
  • BitTorrent clients such as uTorrent.
share|improve this answer
add comment

Almost all my problems are magically solved as soon as i update DirectX components.

Just download the web installer, it'll "do the right thing" and install just the components that your system lacks:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

share|improve this answer
    
My problem was that it went into a black screen after the intro where you swim from the crash into the pod and into rapture.. @ the 2nd load screen. The DX update fixed it. Thanks... –  Gishu Aug 25 '11 at 21:48
add comment

Finally got it working! I had to go to add remove programs and uninstall the program named Rapture 3D Game (or something like that). Now Bioshock works fine!

share|improve this answer
    
Okay i guess it was too soon to post it, now the game starts fine with audio. but once the cut scene is over, there is no audio :( –  NimsDotNet Oct 29 '10 at 15:25
    
Eventually I just reinstalled Bioshock, and it worked fine after that. Good luck, Bioshock is notorious for its audio bugs. –  Raven Dreamer Oct 29 '10 at 18:46
add comment

comes late to the game

I had the exact same problem with windows 7 64 bit, i5 and similar rest of my setup to yours.

To fix follow these steps:

1) Right click your volume control icon
2) Click Playback Devices
3) Click the Recording tab
4) Right click the whitespace somewhere in the scrolling area and click "Show Disabled Devices"
(this part is fuzzy because I'm on a different computer now)
5) Right click the "Stereo Mixing" and click enable
6) Restart steam

Whatever that setting changed fixed the problem for me, and I was having many happy bioshock times last night because of it. =)

share|improve this answer
    
I suspect this answer might fix your "no audio after the cut-scene" problem - I also had this issue, and resolved it by taking a pair of headphones with a mic and plugging them into my mobo's mic slot. It looks ridiculous, but the sound works now. Think I'll try this suggestion instead of continuing that practice. –  Artless Mar 13 '12 at 19:24
    
The research that I did in fixing this problem indicated that it would fix both the splash screen crash and the audio problems. I've had no problems after applying this fix. –  Kenneth Posey Mar 13 '12 at 19:25
add comment

I had this exact same problem game would startup okay and when connecting to Live would hang.

I finally figured out it was a problem with the save files and I backed up this folder elsewhere. This allowed the game to startup without issue but now all my progress was lost. The last step was to pick out my latest save and place it back into the saved games folder hoping it would be good. This worked every time, and if it had failed I would remove that save and go back to the next recent save until I found one that works.

Very annoying but it did allow me to finish the game. I had to do this ~4 times while playing through the single player.

Saves are located here:

My Documents/Bioshock2/SaveGames

share|improve this answer
add comment

I had the exact same issue. Turned out to be some issue with my motherboard's built in sound controller not playing nice with the game. Might be the same thing here, but I'm not 100% sure since that was a Realtek issue and your motherboard has a VIA controller. Might be worth investigating though, tons of issues pop up when Googling Bioshock and Realtek.

share|improve this answer
add comment

Same issue for me was solved by plugging back microphone. Physically.

share|improve this answer
    
Can you elaborate on this? You're saying BioShock was crashing because your microphone wasn't plugged in? –  fredley Feb 4 '13 at 16:17
    
yep, once I had plugged it back game started to work. –  Sergey Grinev Feb 4 '13 at 21:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.