Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Recently, I updated my Minecraft server to snapshot 13w47e. It started up without any trouble. However, upon logging in, I find myself in a new world, without any of my previous items.

Upon further scrutinization, I find that the server is entirely disreguarding the files in the folder it is in. The world is never loaded, no log files are saved, nothing. Not only that, but it never actually generated a world and can run independently in its own empty folder, without creating any files.

Can someone please tell me what is going on? Thanks for any help. I feel I am pretty good with Minecraft servers, but this is beyond strange.

---TECHNICAL DETAILS---

My operating system is Ubuntu 13.04 and I am using the OpenJDK JRE, if that helps at all.

Here is the output of ls -la:

total 8992
drwx------ 4 dillon dillon    4096 Nov 23 08:42 .
drwxr-xr-x 7 dillon dillon    4096 Nov 21 09:01 ..
-rw-rw-r-- 1 dillon dillon     108 Nov 17 13:02 banned-ips.txt
-rw-rw-r-- 1 dillon dillon     186 Nov 17 15:07 banned-players.txt
drwx------ 2 dillon dillon    4096 Nov 18 07:00 logs
-rw-rw-r-- 1 dillon dillon      71 Nov 17 13:02 ops.txt
-rw-rw-r-- 1 dillon dillon 9167277 Nov 23 08:42 server.jar
-rw-rw-r-- 1 dillon dillon     636 Nov 17 13:02 server.properties
-rw-rw-r-- 1 dillon dillon       0 Nov  6 17:39 white-list.txt
drwx------ 8 dillon dillon    4096 Nov 23 08:42 world

and here is the output from ps uax | grep mine:

dillon    4580  0.0  0.0  20428   944 pts/1    S+   15:48   0:00 grep --color=auto mine

This is what I see when I start the server up.

[16:03:33] [Server thread/INFO]: Starting minecraft server version 13w47e
[16:03:33] [Server thread/INFO]: Loading properties
[16:03:33] [Server thread/INFO]: Default game type: SURVIVAL
[16:03:33] [Server thread/INFO]: Generating keypair
[16:03:34] [Server thread/INFO]: Starting Minecraft server on *:25565
[16:03:35] [Server thread/INFO]: Preparing level "world"
[16:03:35] [Server thread/INFO]: Preparing start region for level 0
[16:03:36] [Server thread/INFO]: Preparing spawn area: 0%
[16:03:37] [Server thread/INFO]: Preparing spawn area: 27%
[16:03:38] [Server thread/INFO]: Preparing spawn area: 65%
[16:03:39] [Server thread/INFO]: Done (4.630s)! For help, type "help" or "?"

This startup seems to be much shorter than usual. This is strange because 13w47e added no performance tweaks, so it's hard to tell what's going on.

share|improve this question
    
Was that output with minecraft running? what user do minecraft runs? –  Braiam Nov 23 '13 at 20:43
    
There should only be two users on my computer. One is dillon and the other would be root. –  Dillmo Nov 23 '13 at 20:50
    
Actually there are about 15, but that's not important. How you run Minecraft normally? Dobleclick? Command line? Start as service? as root? –  Braiam Nov 23 '13 at 20:54
    
Here's the command I use: java -Xms2G -Xmx2G -jar server.jar nogui. –  Dillmo Nov 23 '13 at 20:55
    
No errors get printed in the command line? –  Braiam Nov 23 '13 at 21:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.