Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently(yes, late to the party) updated to 1.7.4 on minecraft. Most of the mods I use, however, have not yet updated to that version, so I downgraded to 1.7.2 in order to use them. When I did, I ran into the same issue posted here.

How to install mods for the new Minecraft 1.6.1+ launcher

I would have posted this on that same question, but having never used this site, I had to make an account, and therefor don't have the reputation I need to do so.

Anyway, I followed the steps that the answer shows, to copy and rename the 1.7.2 folder and all of it's contents. After doing that, I tested Minecraft using that version, and it worked. Unfortunately, however, as soon as I added in the mod files to the new versions .jar, any time I tried running minecraft from the launcher, it looks like it's going to run, and then the launcher just comes right back up and I never actually enter the game.

The only mods I've got are Modloader (found here: http://minecraft-mods.org/modloader/) and Timber! (found here: http://minecraft-mods.org/timber-mod/), and a Ovo's Rustic Redemption resource pack(which has been working fine on any version I use). Can anyone tell me where I'm going wrong and what to do to fix it?

Edit: Crash Log

Exception in thread "main" java.lang.VerifyError: (class: acf, method: getChunkGenerator signature: (Labv;Ljava/lang/String;)Ladn;) Wrong return type in function
at abn.l(SourceFile:206)
at kb.b(SourceFile:358)
at azd.<init>(SourceFile:229)
at net.minecraft.client.main.Main.main(SourceFile:84)
Game ended with bad state (exit code 1)
Deleting C:\Users\Owner\AppData\Roaming\.minecraft\versions\Modded 1.7.2\Modded 1.7.2-natives-50399431799411
Ignoring visibility rule and showing launcher due to a game crash
Couldn't delete C:\Users\Owner\AppData\Roaming\.minecraft\versions\Modded 1.7.2\Modded 1.7.2-natives-50399431799411 - scheduling for deletion upon exit

Edit: Another update I tried using Forge, as was suggested in one of the comments. The tutorials for Forge past version 1.6.2 show just dropping the .zip for your mod into a "mods" folder in the .minecraft folder, but when I installed Forge as the tutorials showed, it didn't add a mods folder anywhere, and just creating a mods folder didn't get the mods to run. Minecraft is running with Forge, but lists nothing in the mods, likely because it doesn't know what folder to look for. I then thought maybe I could just add Forge to the Modded-1.7.2.jar, but I had no idea which files I would need to include for that to work, or if it could at all.

share|improve this question
    
Could you add the crash logs? Also, I would use Forge. It contains Forge Mod Loader which is compatible with most Mod Loader mods. –  Cin316 Jan 10 at 0:58
    
@Cin316 Yeah, I'll post the crash logs as soon as I figure out how I can link them. I found them in the development console, but I don't know how to get this site to let me post a .txt file. As for forge, should I put it in the .jar just like I would other mods, and then try loading that up? –  Brandubh Jan 10 at 6:44
    
Okay, crash log is up in OP. –  Brandubh Jan 10 at 13:41
    
I suspect it's a mod conflict. Try disabling mods one by one. If it starts working, then chances are good that the most recently disabled one is the one that caused the issue. –  Frank Jan 10 at 13:50
    
@Frank Seems to be coming from Modloader. I deleted my modded .jar folder, and created a new one, then tested after adding only the Modloader CLASS files, and it's giving me that problem. Tried adding in only Timber!, and the game runs, but the mod doesn't work. I'm gonna try adding in the forge.jar for 1.7.2 and see if it works then. –  Brandubh Jan 10 at 23:44

2 Answers 2

Would the simple solution not be installing Minecraft Forge? 1.7.2 Forge API was made available to everyone a while ago, and it makes modding much easier by installing forge for you directly into the .jar file. Hope that helps,

share|improve this answer

Try replace the '-' instead of spaces, and are you sure you also changed the name of the .jar file and the 'id' in the .json file into the name you given?

If yes, please also include the first 20 lines of the .json file.

share|improve this answer
    
I did change the id in the .json. I'm not quite sure what you mean by the first 20 lines, though, since it's formatted very unusually in the .txt file that it opens. –  Brandubh Jan 11 at 0:10
    
@Brandubh The "first 20 lines" I meant by is the first 20 lines of that .json file, that means you need to copy the line from Line 1 to 20. –  ngbeslhang Jan 13 at 6:52
    
@Brandubh Anyway I recommend you to download Notepad++ to edit the file if you are using Windows (and most gamers will rather to choose Windows OS). –  ngbeslhang Jan 13 at 6:54
    
Yes, I use windows, but when I open the .json in Notepad, there's no "lines." It just shows up as one long string, and I don't know where to cut it into the "lines." –  Brandubh Jan 13 at 23:07
    
@Brandubh I know what you meant by, download Notepad++ (no, not the default Notepad program), it will help you fix this. And it's better if you copy the entire code in the .json file. –  ngbeslhang Jan 17 at 9:12

protected by Community Feb 2 at 18:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.