Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I was wondering if anybody else has tried PCX2 (PS2 Emulator) because I'm wanting to play some old games (i.e. Area 51 and Metal Gear Solid: Sons of Liberty), but everytime I load the games up, I get massive frame drops. I get around 13 frames in game, but cut scenes I get full frames (30-60) any reason why this is?

I've Googled it plently of times, nothing is working.

My specs for my computer are:

  • AMD Athlon 7850 Dual-Core Processor (2.8 GHz)
  • ATI Radeon HD 4650
  • 4 GB DDR2 RAM
share|improve this question
    
Sounds like your video card isn't powerful enough to handle the emulation load. That would explain why the cutscenes are fine, but the game itself lags so badly. –  Frank Jan 10 at 17:52
    
@Frank - I know my hardware is pretty old (in tech years), but I'd thought that since the games are so old, it wouldn't require so much power... :\ –  ErraticFox Jan 10 at 17:55
1  
Emulation requires hardware above and beyond the base tech does, due to the effort of translating it for use on non-standard hardware. If your PC is just at the level of a PS2 (I have no idea what its spec are, though), then you're going to have issues. –  Frank Jan 10 at 17:57
    
I have a little better PC than yours and I too suffer from unplayable lag on 3D games. Sprite ones, like Street Fighter III for example, runs fine.. I really wanted to re-play Valkyrie Profile 2 before my DVD gets damaged or something :( –  RaphaelDDL Feb 14 at 19:54

2 Answers 2

While your video card is older, I know I was able to run PCSX2 on a similar generation Nvidia card 5 years ago. It's not time to give up hope yet.

1) IIRC, PCSX2 comes with 2 binaries that look roughly identical. Try both to see if one works better than the other. I had significant problems with one, but the other worked smoothly on my old setup.

2) Emulation is notoriously finicky, and one configuration tweak might save you. Go through the configuration guide and see if you can adjust your settings to match your slightly outdated hardware.

share|improve this answer

Make sure you're running in Hardware Direct X mode. This is in the graphics plugin settings somewhere. I was getting 10~ FPS in Dark Cloud 2 in software mode at naitive res, now I get solid 60 in 1080p. There are various graphics settings to mess with and it all depends on your hardware, the game and how it interacts with those settings, but Software DX seemed to be on by default and it's a surefire way to ruin performance in 3D games.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.