Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just updated Minecraft Beta from 1.2_01 to 1.2_02 and my saves (I had only one world) seem lost.

Is it possible try to recover it in some way?

share|improve this question
2  
Minecraft is semi-unstable for me lately. I have a script that makes a copy of C:\Users\username\AppData\Roaming\.minecraft\saves every day, a good backup makes recovery far easier. –  Zoredache Jan 22 '11 at 7:20
    
Good suggestion, I will follow it. –  Drake Jan 22 '11 at 12:19
add comment

1 Answer 1

up vote 4 down vote accepted

You may be able to recover it using some of the techniques that are used when the files go missing in power outages. All credit goes to the origional poster, this is located on the minecraft offical forums. I am unsure if this works for upgrade losses but id imagine the backup would still be there unless you have played to the point it recreated? You may be able to check %appdata%.minecraft\saves and see if your world still exists on that side for the recovery attempt.

Tutorial: How to restore missing world after system crash http://www.minecraftforum.net/viewtopic.php?f=17&t=51286

Wish i could be more specific, reply here if you need help or have any concerns.

share|improve this answer
    
It is always best to quote the required steps using > (but still providing the link of course) so one does not have to follow links (that may someday not work for one reason or other) –  Zommuter Jan 21 '11 at 6:08
    
its rather long I was hoping to avoid a huge post for something I wasnt 100% on. No worries Ill keep this in mind as sound advice. –  Ward Jan 21 '11 at 6:12
    
@Tobias - don't quote too extensively though. Stack Exchange doesn't want to fall foul of copyright restrictions. –  ChrisF Jan 21 '11 at 10:01
    
@ChrisF: true, copyright issues should be checked first of course, didn't think of that... –  Zommuter Jan 21 '11 at 10:37
    
I read the topic and I tried deleting level.dat and replacing with one of a new world just created, and removing the most recent numeric sub-folder and it worked. I lost all things I carried with me, but better then nothing :) –  Drake Jan 22 '11 at 12:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.