Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am getting massive 2-second lag spikes every 3 seconds while playing FTB Monster, including in menus and the inventory screen.

I am not playing on a flash drive, and turning the graphics settings to minimum levels has not reduced the spikes one bit.

Despite this, the debug data shows that the majority of memory use is switching between gameRenderer and render, and either the entities or the terrain.

This is a newly generated world (ATG worldgen) that I'm just exploring on creative. I'm not even adding or breaking blocks. I get the spikes whether I'm moving to new terrain or wandering old ones, so it's not waiting for the chunk to generate. I'm on peaceful, so there are no more than maybe 10 passive vanilla animals rendered at any one time.

Optifine is not compatible at all with FTB Monster (crashes on startup), and I get a good 70 fps when using fancy settings and normal render distance while I'm playing vanilla.

I didn't get these spikes when I was playing FTB Horizons (though a reduced 25 fps), so it's probably due to one of the mods in Monster.

Any ideas which one could be doing this?

share|improve this question
    
check your console, you may be expieriencing the same issue I was. –  Ender Feb 3 at 0:39
    
I believe MapWriter in the Monster pack has some memory issues, unless they've fixed it. If you open your F3 menu, you should be able to see that the Used Memory steadily increases upto a certain point, then you encounter a lag spike. Once the spike ends the memory gets reduced to much lower usage again. I found that assigning more RAM in the FTB launcher settings allowed for enough spare memory for it to not hit the limit, and the lagspikes disappeared. –  Viprus Feb 5 at 16:36

5 Answers 5

up vote 1 down vote accepted

I was using v1.0.5. This was fixed in v1.0.9. Just go to the launcher and instead of recommended, hit v1.0.9 instead. Now my lag is normal, not spiking.

share|improve this answer

It is quite possible that your computer simply can't handle all the mods in Monster, as it is quite demanding with the HUGE amount of mods on it, but it may not be the case because of the lag on menu screens.

share|improve this answer

I think your computer cant handle it like the answer above.It depends on how much mods you have.It looks like the pack has over 90+ mods which is intense for a computer. Try giving more ram to FTB if your computer can handle it.When you open the FTB launcher go on options and there should be a RAM maximum with a slide bar.Slid that over to the right a bit and test.Adjust as much as you need to just make sure you leave enough ram for other applications

share|improve this answer

Set the maximum ram as high as you can. It was set to 1024 by default. I adjusted mine to 8000 and the lags more or less disapeared.

share|improve this answer
    
I've done that before. It's usually not a good idea to allocate all of your RAM, you actually create even more lag, keeping it unavailable for system use, and can damage your save file, system files, or even the ram sticks themselves. –  einsteinsci Mar 8 at 23:15

I just needed to mess with my computer variables because i had it set to only 1024M, now i have 4gigs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.