Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Is there a way to alt-tab out of Minecraft (i.e. make Minecraft lose focus) without the game auto-pausing and without having to bring a menu (e.g. inventory) up first?

share|improve this question
2  
What's the problem with having a menu up? Granted, it would be nice otherwise, but is it causing any specific problems you're trying to avoid? –  Cyclops Jan 31 '11 at 13:47
    
It fills most of the screen and dims the bits that it doesn't fill. That makes me a bit nervous, as I can't see what's going on. –  Cosmic Flame Jan 31 '11 at 20:23

6 Answers 6

up vote 22 down vote accepted

For single player, it seems that you've already figured out that bringing up the inventory screen prevents the game from auto-pausing when it loses focus. I don't believe there is any other way to prevent the auto pausing.

You may, however, consider hosting a SMP server and being the only person connected to it. In SMP, the game will not pause when you are alt-tabbed out. You can install mods on a SMP server that allow you to create user whitelists to define who you want to connect to your server. If you add only yourself to that list, you don't need to worry about anyone else connecting while you are playing.

share|improve this answer
    
Thank you, that's a really good idea! Is it possible to pause an SMP game at all, by the way? –  Cosmic Flame Jan 31 '11 at 13:47
    
Hmm.. I'm not sure, since I've never actually run an SMP server, only played on them. I would assume there's a command to do it, and I'm sure it happens if you stop the server. If you don't want the game to continue when you're not playing, simply stopping the server when you stop playing seems to be an easy solution. –  Dave McClelland Jan 31 '11 at 13:50
1  
@Cosmic - Another thing I wanted to mention - whether you're playing SSP or SMP, alt-tabbing will bring up the same menu as when you hit escape. The difference is that when on an SMP server, the game won't pause in the background. If this isn't sufficient, you probably won't find an easy solution to the problem. –  Dave McClelland Jan 31 '11 at 13:52
3  
@Cosmic Flame Yes, via /stop. :) –  Ullallulloo Mar 1 '11 at 0:33
    
Thanks :) Very helpful. –  Cosmic Flame Mar 1 '11 at 9:35

Go into your minecraft folder and open up options.txt. Find the line that reads

pauseOnLostFocus:true

and change true to false. Now Minecraft won't pause to the menu screen when you tab away.


You can find your minecraft folder in a couple ways:

  1. Using the file system: Navigate to...

    • %appdata%\.minecraft\ (on Windows)
    • ~/Library/Application Support/minecraft/ (on Mac OS X)
    • ~/.minecraft/ (on Linux)
  2. Using Minecraft's menus:

    1. Start Minecraft and click Options, Resource Packs, and then Open resource packs folder. In the file system window that opens, go up one folder and you'll be in your minecraft folder.
share|improve this answer
    
This is definately the best way to do so that you don't have to change how your world works –  Flaunting Aug 1 at 12:09

Since the update that merged the single- and multi-player code bases, you can press T to start typing in chat, which will let you tab out without pausing or hiding the game.

share|improve this answer

This answer is no longer relevant to current Minecraft versions, because F1 no longer hides menus; also, F1 is now a toggle and the tricks for holding it down are irrelevant.

Since you mention that your concern is that you can't see (as opposed to having the menu up at all), I have a fix for that: with the menu up, use F1 to hide it. Pressing F1 removes all HUD elements and leaves only the game view.

However, you have to hold down F1. There are several tricks for this to fool the game into thinking you have F1 down:

  • Press F1 and switch out of Minecraft while holding it down. (Tested on Mac)
  • Before releasing F1, press the Alt (Windows (and Linux?)) or ⌘ Command (Mac) keys.
  • Mac-specific: If you have a system where you have to press fn-F1, just release F1 before fn.
share|improve this answer
    
Genius! I'll try that tonight, thanks :) –  Cosmic Flame Feb 1 '11 at 13:31

You can press F3+P to let the game not auto-pausing. Press F3+P again to re-enable it.

share|improve this answer
    
Does not work for me. –  Corporal Touchy Aug 1 at 15:59
    
It works very well for me (no message is displayed but it works). –  iKiWiXz Oct 30 at 22:07

Whilst all the other solutions look perfectly fine, I thought I'd add the method I use, when I want to not have the game pause, I hit esc, and "Open up to LAN". The game doesn;t pause then on focus loss.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.