Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Launching the 64-bit exe of the game (through Steam) gives crashes and writes a dump with the following:

Process Name             Application-steam-x64.exe
Process Architecture     x64
Exception Code           0xC0000005
Exception Information    The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information         Not Present

The 32-bit executable works fine, but that is not the one that Steam launches, so launching it is a bit inconvenient. Running the 64-bit version as administrator does not help, nor does compatibility mode. I'm using Windows 8.1 x64 Pro, AMD processor and NVIDIA GTX 780.

Is there some other workaround to this than using the 32-bit version?

share|improve this question
    
Are you on a 64-bit system? –  SaintWacko Feb 18 at 20:13
    
@SaintWacko Yes. –  3ventic Feb 18 at 20:14
    
...Was that bit in the question body about your computer there, and I just overlooked it? –  SaintWacko Feb 18 at 20:21
    
@SaintWacko Pretty much –  3ventic Feb 18 at 20:57

3 Answers 3

I have had the same issue. Crash dump looks like it's dying starting up DX11 - you can force the game into DX9 mode with some registry editing, if you're comfortable with that. (regedit.exe)

If you navigate to, (or you might have to add)
HKEY_CURRENT_USER\Software\Shining Rock Software LLC\Banished

Then add a new string value (not integer!)

name: VideoInterface 
value: 0

That fixed it for me.

share|improve this answer
2  
If you're not a techy, you can just download this registry file and import it to your registry. It will apply the fix as described by Andew. –  Mario Feb 19 at 16:10

Go into Program Files (x86)/Steam/...SteamApps/common/Banished

and cut the files VideoDX11-steam-x64.dll and VideoDX11-steam-x32.dll into a new folder. Game started perfectly after that for me!

share|improve this answer
up vote 0 down vote accepted

As of version 1.0.1 you can use the command-line parameter /dx9 to force the game to DirectX 9.0c mode and fix the crash.

Using the command-line parameter

All versions

  • Create a shortcut for Banished 64-bit executable (Application-steam-x64.exe for Steam version)
  • Edit the shortcut properties and add /dx9 to the end of the "Target" field:

Target: mmon/Banished/Application-steam-x64.exe /dx9

Steam only

  • Banished > Properties > Set launch options
  • Add /dx9 to the field shown:

Banished - Properties - Set launch options... - /dx9

Notes

  • This does not save the setting and will only use it as long as the parameter is present. Removing the parameter will revert to the default setting (which can be the same!)
  • Similarly, you can use /dx11 to force the game to use DirectX 11.
share|improve this answer

protected by Community Mar 4 at 21:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.