Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a CentOS 6.5 machine at home with bukkit 1.7.2-R0.3 on 10.0.0.13:25570. When the server boots I get this. When I connect from my Windows 7 Minecraft 1.7.5 I get Failed to connect to the server. java.net.ConnectException: Connection timed out: no further information

Server log

Loading libraries, please wait...
[12:07:12 INFO]: Starting minecraft server version 1.7.2
[12:07:12 INFO]: Loading properties
[12:07:12 INFO]: Default game type: SURVIVAL
[12:07:12 INFO]: Generating keypair
[12:07:12 INFO]: Starting Minecraft server on *:25570
[12:07:12 INFO]: This server is running CraftBukkit version git-Bukkit-1.7.2-R0.3-b3020jnks (MC: 1.7.2) (Implementing API version 1.7.2-R0.3)
[12:07:12 INFO]: [Lockette] Loading Lockette v1.7.10
[12:07:12 INFO]: [WorldEdit] Loading WorldEdit v5.5.1
[12:07:12 INFO]: [AutoSaveWorld] Loading AutoSaveWorld v4.4
[12:07:12 INFO]: [NoSwear] Loading NoSwear v5.4
[12:07:12 INFO]: [WarpSigns] Loading WarpSigns v2.0
[12:07:12 INFO]: [Essentials] Loading Essentials v2.10.1
[12:07:12 INFO]: [EssentialsChat] Loading EssentialsChat v2.10.1
[12:07:12 INFO]: [EssentialsProtect] Loading EssentialsProtect v2.10.1
[12:07:12 INFO]: MLog clients using java 1.4+ standard logging.
[12:07:12 INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.10.1
[12:07:12 INFO]: Preparing level "duckcraft3"
[12:07:13 INFO]: Preparing start region for level 0 (Seed: -2163741875980949662)
[12:07:13 INFO]: Preparing start region for level 1 (Seed: -2163741875980949662)
[12:07:13 INFO]: Preparing start region for level 2 (Seed: -2163741875980949662)
[12:07:13 INFO]: [Lockette] Enabling Lockette v1.7.10
[12:07:13 INFO]: [Lockette] Version 1.7.10 is being enabled!  Yay!  (Core version 1.3.7)
[12:07:13 INFO]: [Lockette] Detected craftbukkit build [3020] ok.
[12:07:13 INFO]: [Lockette] Custom lockable block list: [116, 84, 57, 145]
[12:07:13 INFO]: [Lockette] Ignoring linked plugins: [mcMMO]
[12:07:13 INFO]: [Lockette] Loading strings file for English by Acru
[12:07:13 INFO]: [Lockette] Using ops file for admin permissions.
[12:07:13 INFO]: [Lockette] Ready to protect your containers.
[12:07:13 INFO]: [WorldEdit] Enabling WorldEdit v5.5.1
[12:07:14 INFO]: WEPIF: Using the Bukkit Permissions API.
[12:07:14 INFO]: [AutoSaveWorld] Enabling AutoSaveWorld v4.4
[12:07:14 INFO]: [AutoSaveWorld] Version 4.4 is enabled: 9a6b3334-8cef-407d-aad3-ed94ed94aef9
[12:07:14 INFO]: [NoSwear] Enabling NoSwear v5.4
[12:07:14 INFO]: [AutoSaveWorld] AutoSaveThread Started: Interval is 600 seconds, Warn Times are 0
[12:07:14 INFO]: [AutoSaveWorld] AutoBackupThread Started: Interval is 28800 seconds, Warn Times are 0
[12:07:14 INFO]: [AutoSaveWorld] AutoPurgeThread Started: Interval is 86400 seconds, Warn Times are 0
[12:07:14 INFO]: [NoSwear] Enabled! Config Loaded! Kicking!
[12:07:14 INFO]: [WarpSigns] Enabling WarpSigns v2.0
[12:07:14 INFO]: WarpSigns version 2.0 is enabled!
[12:07:14 INFO]: [Essentials] Enabling Essentials v2.10.1
[12:07:14 INFO]: Essentials: Using config file enhanced permissions.
[12:07:14 INFO]: Permissions listed in as player-commands will be given to all users.
[12:07:14 INFO]: [EssentialsChat] Enabling EssentialsChat v2.10.1
[12:07:14 INFO]: [EssentialsProtect] Enabling EssentialsProtect v2.10.1
[12:07:17 INFO]: ----- Bukkit Auto Updater -----
[12:07:17 INFO]: It appears that you're running a Beta Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
[12:07:17 INFO]: If you would like to be kept informed about new Beta Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'beta'.
[12:07:17 INFO]: With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
[12:07:17 INFO]: If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
[12:07:17 INFO]: ----- ------------------- -----
[12:07:19 INFO]: Initializing c3p0-0.9.1.2 [built 21-May-2007 15:04:56; debug? true; trace: 10]
[12:07:19 INFO]: [EssentialsSpawn] Enabling EssentialsSpawn v2.10.1
[12:07:19 INFO]: Server permissions file permissions.yml is empty, ignoring it
[12:07:19 INFO]: Done (6.745s)! For help, type "help" or "?"
share|improve this question
    
Uh. Why are you trying to connect to a 1.7.2 server with a 1.7.5 client? Those two numbers have to match. –  aman207 Mar 1 at 17:55
2  
@aman207 not true, works fine with 1.7.5 client. –  Mark Allison Mar 1 at 20:33
    
I would recommand running the MC server on port 25565 instead of your current one, 25570. That way players don't need to add a port to your server address when they connect. –  Frithjof Mar 2 at 18:08
    
@Frithjof I already have another MC server on that port. :) –  Mark Allison Mar 3 at 7:55

1 Answer 1

up vote 2 down vote accepted

If you haven't checked already, make sure you have an exception for port 25570 in your iptables for internal connections. Not sure if this is something that could affect it, but it's worth looking into.

share|improve this answer
    
That was exactly it, I had forgotten to add the rule. Thanks! –  Mark Allison Mar 1 at 20:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.