Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I bought a Windows 7 machine and went to install Civilization IV on it. It told me the program had "known problems". If I continue it begins the startup process but eventually fails. What do I need to do to get it working?

share|improve this question
I run CivIV on my Win7 machine all the time and have never had the least trouble. Is there something else unusual about your computer? – JSBձոգչ Feb 4 '11 at 1:16
Brand new Dell. Windows 7 Home Premium. – DJClayworth Feb 4 '11 at 18:16
up vote 3 down vote accepted

OK I got this working and it seems you need to do two things.

  1. Update DirectX. The one from the Civ 4 disk may work, or this:
  2. Upgrade the game to version 1.74, which can be downloaded. Firaxis appears to no longer support this patch, but it is available from Gamespy:

The DirectX upgrade may or may not have been necessary. It certainly doesn't work without the patch upgrade. You don't need any of the Windows 7 compatibility modes.

share|improve this answer

Did you try just ignoring that message and continuing on with the install? I've run Civ 4 on my Windows 7 machine and haven't experienced any issues.

share|improve this answer
This should work – Viper_Sb Feb 3 '11 at 19:53
It does eventually fail to load. I've edited to reflect that. – DJClayworth Feb 3 '11 at 21:29

Updating my graphic card driver solved this problem for me.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – MBraedley Jul 28 '13 at 21:38

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.