Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a somewhat slow internet (2MBs), but the real problem is that I have a really small data cap during the day.

I'm currently downloading the game (at night) but since I have a slow connection this will take a while.

I've reached the playable level in the download in the launcher, but even though I've paused the download, whenever I go in game, the background download goes back to full speed as soon as I hit the hero selection screen. Is there any way to stop it or limit it to only essential things instead of it resuming downloading everything in game?

share|improve this question
    
Getting to playable is usually a good majority of the download. If you don't want it to download while you play, why not just finish the rest? –  Katustrawfic Mar 17 at 16:53
    
I've been waiting for 4 days and it's less than half way through :( –  Pat Mar 17 at 16:59
    
@Katustrawfic getting to playable is actually only about 1/4th of the full download. –  Chippies Mar 20 at 16:07

3 Answers 3

up vote 1 down vote accepted

You can't. AIUI When it reaches the "playable" stage it has the game code downloaded, but not all of the assets. As you play, it streams levels, textures, sound effects, etc as (or before) they are needed. As such, it is only playable by downloading stuff as it goes. If you want to play without this happening, you will need to wait for the download to finish first.

share|improve this answer

While you could try to Check to make sure "Pause updates when I launch game" in Battle.net settings like in this screenshot update pause checkmark diablo 3

or you could create a shortcut to "Diablo III.exe" and add -launch in target field in properties of the shortcut to bypass battle.net software. Example: (Replace the path with your own)shortcut

I would recommend finding a way to finish the download however, because "playable" only means you have enough for the first act or maybe two, there's still information required to be downloaded to play the full game.

share|improve this answer
    
The weird thing is I've tried both and none work. I even tried limiting the network bandwith speeds to 1KB/s, but that seems to work only inside the launcher. :/ –  Pat Mar 17 at 16:48
1  
"Playable" might not even get you the first act. As far as I know, it basically only allows launching the game. –  MBraedley Mar 17 at 16:49
    
Yes, I had to wait while it downloaded/loaded in a few areas. But I don't know why it keeps downloading even in areas that have already downloaded and loaded. –  Pat Mar 17 at 16:51
    
It keeps downloading so you wouldn't have to stop and wait for it to finish downloading every time you reach a new area. By using the shortcut method, did you turn Battle.net software off? I think the software is what updates the game, but I could be wrong... –  Chippies Mar 17 at 17:02
    
This answer is wrong - doing this will not help one to play a game that is not fully downloaded without streaming. –  Simon W Mar 19 at 9:58

Click the Installation & Updates Options then Settings. That should let you change how its downloading when you are playing. I've had to do this because mine continued to download (much like yours).

There is not a way to download only "essential" things. Or better yet there is only a way to download "essential" things.

Background Download

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.